CVE-2026-47212 Symfony: Twilio SMS Notifier allows unauthenticated webhook injection due to missing X-Twilio-Signature verification
Attackers can inject forged Twilio status payloads via unauthenticated requests because the webhook parser ignores signature verification, affecting Symfony applications using the Twilio Notifier component.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-47212?
CVE-2026-47212 is a medium-severity missing authorization vulnerability in Sensiolabs Symfony, published on 14 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Symfony is a PHP framework for web and console applications and a set of reusable PHP components. Prior to 6.4.40, 7.4.12, and 8.0.12, TwilioRequestParser::doParse() received the configured webhook secret but ignored the X-Twilio-Signature HMAC header, allowing unauthenticated POST requests to inject forged Twilio status payloads. This issue is fixed in versions 6.4.40, 7.4.12, and 8.0.12.
Which versions are affected by CVE-2026-47212?
12 open source packages ship an affected version, including symfony/symfony and symfony/twilio-notifier. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
symfony/symfony Packagist | From 6.4.0 | 6.4.40 |
symfony/symfony Packagist | From 6.4.0 | 6.4.40 |
symfony/symfony Packagist | From 7.0.0 | 7.4.12 |
symfony/symfony Packagist | From 7.0.0 | 7.4.12 |
symfony/symfony Packagist | From 8.0.0 | 8.0.12 |
symfony/symfony Packagist | From 8.0.0 | 8.0.12 |
6 more packages
symfony/twilio-notifier Packagist | From 6.4.0 | 6.4.40 |
symfony/twilio-notifier Packagist | From 6.4.0 | 6.4.40 |
symfony/twilio-notifier Packagist | From 7.0.0 | 7.4.12 |
symfony/twilio-notifier Packagist | From 7.0.0 | 7.4.12 |
symfony/twilio-notifier Packagist | From 8.0.0 | 8.0.12 |
symfony/twilio-notifier Packagist | From 8.0.0 | 8.0.12 |
Products include Sensiolabs Symfony.
How do I fix CVE-2026-47212?
Upgrade symfony/symfony to a fixed version for your release line: 6.4.40, 7.4.12 or 8.0.12.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2026-47212 being exploited?
There is no known exploitation of CVE-2026-47212 in the wild and no public exploit code.
Other vulnerabilities in Sensiolabs Symfony
Sources
Also known as DEBIAN-CVE-2026-47212, GHSA-55rj-x2vc-4whq, UBUNTU-CVE-2026-47212.