CVE-2026-47216 Typesense: Unauthenticated Denial of Service in the Typesense /multi_search Endpoint

High 8.7 Published Updated

Unauthenticated attackers can crash the Typesense server via a crafted request to the multi_search endpoint, causing service unavailability.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2026-47216?

CVE-2026-47216 is a high-severity denial of service vulnerability in typesense, published on 12 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Typesense is a fast, typo-tolerant search engine. Prior to versions 29.1 and 30.2, there is an unauthenticated denial-of-service vulnerability in the /multi_search endpoint. A specially crafted request can trigger an unhandled exception during request processing, causing the server process to terminate. This issue can be exploited over the network without authentication and results in service unavailability. The duration of impact may vary depending on system configuration and dataset size. This issue has been patched in versions 29.1 and 30.2.

Weakness: CWE-754

Which versions are affected by CVE-2026-47216?

How do I fix CVE-2026-47216?

No fix has been published for CVE-2026-47216 yet. Limit exposure of the affected software until one is available.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2026-47216 being exploited?

There is no known exploitation of CVE-2026-47216 in the wild and no public exploit code.

Sources

Also known as GHSA-fpx5-8c99-247j.

Is CVE-2026-47216 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free