# CVE-2026-47216: Typesense: Unauthenticated Denial of Service in the Typesense /multi_search Endpoint

> Unauthenticated attackers can crash the Typesense server via a crafted request to the multi_search endpoint, causing service unavailability.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 12 Jun 2026
- **Updated:** 12 Jun 2026
- **Also known as:** GHSA-fpx5-8c99-247j

## What is CVE-2026-47216?

CVE-2026-47216 is a high-severity denial of service vulnerability in typesense, published on 12 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Typesense is a fast, typo-tolerant search engine. Prior to versions 29.1 and 30.2, there is an unauthenticated denial-of-service vulnerability in the /multi_search endpoint. A specially crafted request can trigger an unhandled exception during request processing, causing the server process to terminate. This issue can be exploited over the network without authentication and results in service unavailability. The duration of impact may vary depending on system configuration and dataset size. This issue has been patched in versions 29.1 and 30.2.

Weakness: CWE-754 (Improper Check for Unusual or Exceptional Conditions)

## Which versions are affected by CVE-2026-47216?


## How do I fix CVE-2026-47216?

No fix has been published for CVE-2026-47216 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-47216 being exploited?

There is no known exploitation of CVE-2026-47216 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-47216 and fix it if it is affected.

What it is: CVE-2026-47216 is a high-severity denial of service vulnerability in typesense, published on 12 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-47216 in the wild and no public exploit code.

Affected product: typesense. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-47216/ (Markdown: https://insights.sbomify.com/CVE-2026-47216/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-47216
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-47216
- OSV: https://osv.dev/vulnerability/CVE-2026-47216

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-47216/
Summaries are generated and may contain mistakes; the official description above is the record.
