# CVE-2026-47225: Improper Search Cache Isolation for Scoped Search API Keys in Typesense

> Attackers can view restricted search results by exploiting cache isolation flaws when using scoped API keys and server-side caching.

- **Severity:** Medium 6.0 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 12 Jun 2026
- **Updated:** 12 Jun 2026
- **Also known as:** GHSA-97x4-gm45-jpcw

## What is CVE-2026-47225?

CVE-2026-47225 is a medium-severity vulnerability in typesense, published on 12 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Typesense is a fast, typo-tolerant search engine. Prior to versions 29.1 and 30.2, there is a cache isolation issue affecting search requests that use both server-side search result caching and Scoped Search API Keys. Under specific request ordering, cached search results could be reused across requests with different Scoped Search API Key constraints. This could result in a request receiving search results that should have been restricted by its Scoped Search API Key. This issue only affects search requests that use both server-side search result caching and Scoped Search API Keys with embedded filters to restrict access to search results within a collection. This vulnerability may result in unintended disclosure of search results across scoped authorization contexts. This issue has been patched in versions 29.1 and 30.2.

Weakness: CWE-524 (Use of Cache Containing Sensitive Information)

## Which versions are affected by CVE-2026-47225?


## How do I fix CVE-2026-47225?

No fix has been published for CVE-2026-47225 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-47225 being exploited?

There is no known exploitation of CVE-2026-47225 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-47225 and fix it if it is affected.

What it is: CVE-2026-47225 is a medium-severity vulnerability in typesense, published on 12 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-47225 in the wild and no public exploit code.

Affected product: typesense. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-47225/ (Markdown: https://insights.sbomify.com/CVE-2026-47225/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-47225
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-47225
- OSV: https://osv.dev/vulnerability/CVE-2026-47225

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-47225/
Summaries are generated and may contain mistakes; the official description above is the record.
