# CVE-2026-47243: Kata guest escape: runtime-rs guest-root to host-root escape via virtiofs

> Guest root can escape to host root via virtiofs path traversal in non-default runtime-rs configurations, enabling arbitrary code execution on the host.

- **Severity:** Critical 9.2 (`CVSS:4.0/AV:L/AC:L/AT:N/PR:H/UI:N/VC:H/VI:H/VA:N/SC:H/SI:H/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Aug 2026
- **Updated:** 10 Aug 2026
- **Also known as:** AZL-94607, GHSA-2gv2-cffp-j227, GO-2026-5042, OESA-2026-2527, OESA-2026-2528, OESA-2026-2557

## What is CVE-2026-47243?

CVE-2026-47243 is a critical path traversal vulnerability in kata-containers, published on 7 Aug 2026. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Kata Containers is an open source project focusing on a standard implementation of lightweight Virtual Machines (VMs) that perform like containers. Prior to 3.31.0, the runtime-rs standalone virtio-fs path is vulnerable to a guest-root to host-root escape. In this configuration, Kata runs the host virtiofsd as root with --sandbox none --seccomp none, so an attacker with root-equivalent access inside the guest can bypass the guest virtio-fs client entirely by taking over the virtio-fs PCI device and building a virtqueue in userspace to submit raw FUSE requests directly to the host virtiofsd. A crafted FUSE_SYMLINK request whose new symlink name is an absolute host path is honored outside the configured shared directory, allowing guest root to create root-owned symlinks in sensitive host locations such as /etc/cron.d. By pointing such a symlink at a guest-controlled crontab payload reachable through a live runtime process's mount namespace, the attacker causes the host cron daemon to execute that payload as host root, crossing the Kata isolation boundary. This issue is fixed in version 3.31.0.

Weakness: CWE-36 (Absolute Path Traversal), CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2026-47243?

3 open source packages ship an affected version, including github.com/kata-containers/kata-containers.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/kata-containers/kata-containers` | Go | All versions | 0.0.0-20260519062212-ffa59ce3aa78 |
| `github.com/kata-containers/kata-containers` | Go | All versions | 0.0.0-20260519062212-ffa59ce3aa78 |
| `github.com/kata-containers/kata-containers` | Go | All versions | 0.0.0-20260519062212-ffa59ce3aa78 |

## How do I fix CVE-2026-47243?

Upgrade github.com/kata-containers/kata-containers to 0.0.0-20260519062212-ffa59ce3aa78 or later.

## Is CVE-2026-47243 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-47243 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-47243 and fix it if it is affected.

What it is: CVE-2026-47243 is a critical path traversal vulnerability in kata-containers, published on 7 Aug 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-47243 exists.

Affected packages and fixed versions:
- github.com/kata-containers/kata-containers (Go): affected all versions; fixed in 0.0.0-20260519062212-ffa59ce3aa78
- github.com/kata-containers/kata-containers (Go): affected all versions; fixed in 0.0.0-20260519062212-ffa59ce3aa78
- github.com/kata-containers/kata-containers (Go): affected all versions; fixed in 0.0.0-20260519062212-ffa59ce3aa78

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-47243/ (Markdown: https://insights.sbomify.com/CVE-2026-47243/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-47243
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-47243
- OSV: https://osv.dev/vulnerability/CVE-2026-47243

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-47243/
Summaries are generated and may contain mistakes; the official description above is the record.
