# CVE-2026-47245: MyBB: Buddy list corruption


- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Fix available:** No
- **Published:** 18 Aug 2026
- **Updated:** 18 Aug 2026
- **Also known as:** GHSA-w8gm-j57p-jqpc

## What is CVE-2026-47245?

CVE-2026-47245 is a medium-severity vulnerability in mybb, published on 18 Aug 2026. 

### Official description

MyBB is free and open source forum software. Prior to 1.8.40, the User CP Buddy/Ignore List component does not validate reciprocal buddy-list updates correctly. The usercp.php?action=do_editlists delete handler removes the selected entry from the acting user's list and then updates mybb_users.buddylist for the target account. The reciprocal update searches for the deleted target UID instead of the acting user's UID and uses the unchecked array_search() return value as an array key. A false result can be converted to index 0, removing the target account's first stored buddy while leaving the actual reciprocal entry unchanged. The uniquely identifying implementation details include false converted to index 0. This issue is fixed in version 1.8.40.

Weakness: CWE-252 (Unchecked Return Value)

## Which versions are affected by CVE-2026-47245?


## How do I fix CVE-2026-47245?

No fix has been published for CVE-2026-47245 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-47245 being exploited?

There is no known exploitation of CVE-2026-47245 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-47245 and fix it if it is affected.

What it is: CVE-2026-47245 is a medium-severity vulnerability in mybb, published on 18 Aug 2026. 
Exploitation: There is no known exploitation of CVE-2026-47245 in the wild and no public exploit code.

Affected product: mybb. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-47245/ (Markdown: https://insights.sbomify.com/CVE-2026-47245/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-47245
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-47245
- OSV: https://osv.dev/vulnerability/CVE-2026-47245

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-47245/
Summaries are generated and may contain mistakes; the official description above is the record.
