CVE-2026-47248 Parse Server: GraphQL "Did you mean" validation suggestions disclose schema to unauthenticated callers
Unauthenticated attackers can reconstruct GraphQL schema details via error messages, exposing internal structure to anyone with the public app ID.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-47248?
CVE-2026-47248 is a medium-severity vulnerability in parse-community parse-server, published on 12 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to versions 8.6.78 and 9.9.1-alpha.2, Parse Server's GraphQL endpoint discloses schema metadata to unauthenticated callers through Did you mean ...? suggestions embedded in GraphQL validation-error messages. An unauthenticated caller who knows only the public application id can iteratively send malformed queries to reconstruct class names, field names, argument names, mutation names, and input-object fields. This issue has been patched in versions 8.6.78 and 9.9.1-alpha.2.
Weakness: CWE-209
Which versions are affected by CVE-2026-47248?
5 open source packages ship an affected version, including parse-server and parse.
| Package | Affected | Fixed in |
|---|---|---|
parse-server npm | All versions | 8.6.78 |
parse-server npm | All versions | 8.6.78 |
parse-server npm | From 9.0.0 | 9.9.1-alpha.2 |
parse-server npm | From 9.0.0 | 9.9.1-alpha.2 |
parse Bitnami | All versions | 8.6.78, 9.9.1 |
How do I fix CVE-2026-47248?
Upgrade parse-server to a fixed version for your release line: 8.6.78 or 9.9.1-alpha.2.
Is CVE-2026-47248 being exploited?
There is no known exploitation of CVE-2026-47248 in the wild and no public exploit code.
Sources
Also known as BIT-parse-2026-47248, GHSA-8cph-rgr4-g5vj.