# CVE-2026-47248: Parse Server: GraphQL "Did you mean" validation suggestions disclose schema to unauthenticated callers

> Unauthenticated attackers can reconstruct GraphQL schema details via error messages, exposing internal structure to anyone with the public app ID.

- **Severity:** Medium 6.9 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Jun 2026
- **Updated:** 12 Jun 2026
- **Also known as:** BIT-parse-2026-47248, GHSA-8cph-rgr4-g5vj

## What is CVE-2026-47248?

CVE-2026-47248 is a medium-severity vulnerability in parse-community parse-server, published on 12 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to versions 8.6.78 and 9.9.1-alpha.2, Parse Server's GraphQL endpoint discloses schema metadata to unauthenticated callers through Did you mean ...? suggestions embedded in GraphQL validation-error messages. An unauthenticated caller who knows only the public application id can iteratively send malformed queries to reconstruct class names, field names, argument names, mutation names, and input-object fields. This issue has been patched in versions 8.6.78 and 9.9.1-alpha.2.

Weakness: CWE-209 (Generation of Error Message Containing Sensitive Information)

## Which versions are affected by CVE-2026-47248?

5 open source packages ship an affected version, including parse-server and parse.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `parse-server` | npm | All versions | 8.6.78 |
| `parse-server` | npm | All versions | 8.6.78 |
| `parse-server` | npm | From 9.0.0 | 9.9.1-alpha.2 |
| `parse-server` | npm | From 9.0.0 | 9.9.1-alpha.2 |
| `parse` | Bitnami | All versions | 8.6.78, 9.9.1 |

## How do I fix CVE-2026-47248?

Upgrade parse-server to a fixed version for your release line: 8.6.78 or 9.9.1-alpha.2.

## Is CVE-2026-47248 being exploited?

There is no known exploitation of CVE-2026-47248 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-47248 and fix it if it is affected.

What it is: CVE-2026-47248 is a medium-severity vulnerability in parse-community parse-server, published on 12 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-47248 in the wild and no public exploit code.

Affected packages and fixed versions:
- parse-server (npm): affected all versions; fixed in 8.6.78
- parse-server (npm): affected all versions; fixed in 8.6.78
- parse-server (npm): affected from 9.0.0; fixed in 9.9.1-alpha.2
- parse-server (npm): affected from 9.0.0; fixed in 9.9.1-alpha.2
- parse (Bitnami): affected all versions; fixed in 8.6.78, 9.9.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-47248/ (Markdown: https://insights.sbomify.com/CVE-2026-47248/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-47248
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-47248
- OSV: https://osv.dev/vulnerability/CVE-2026-47248

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-47248/
Summaries are generated and may contain mistakes; the official description above is the record.
