# CVE-2026-47260: Koel Vulnerable to SSRF via Podcast Episode Enclosure URLs

> Attackers can exploit unvalidated podcast enclosure URLs to perform Server-Side Request Forgery, reading data from internal services.

- **Severity:** High 7.7 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Jun 2026
- **Updated:** 13 Jun 2026
- **Also known as:** GHSA-7j2f-6h2r-6cqc

## What is CVE-2026-47260?

CVE-2026-47260 is a high-severity server-side request forgery vulnerability in koel, published on 12 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Koel is a free, open-source music streaming solution. Prior to version 9.3.5, Koel validates the podcast feed URL via the SafeUrl rule (DNS resolution + public IP check), but the individual episode <enclosure url="..."> values extracted from the RSS XML are stored directly into the database without any SSRF validation. When a user plays an episode, the server downloads the full HTTP response from the unvalidated enclosure URL via Http::sink()->get() and streams it back to the user, enabling full-read SSRF against internal services. This issue has been patched in version 9.3.5.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2026-47260?

2 open source packages ship an affected version, including phanan/koel.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `phanan/koel` | Packagist | All versions | 9.3.5 |
| `phanan/koel` | Packagist | All versions | 9.3.5 |

## How do I fix CVE-2026-47260?

Upgrade phanan/koel to 9.3.5 or later.

## Is CVE-2026-47260 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-47260 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-47260 and fix it if it is affected.

What it is: CVE-2026-47260 is a high-severity server-side request forgery vulnerability in koel, published on 12 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-47260 exists.

Affected packages and fixed versions:
- phanan/koel (Packagist): affected all versions; fixed in 9.3.5
- phanan/koel (Packagist): affected all versions; fixed in 9.3.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-47260/ (Markdown: https://insights.sbomify.com/CVE-2026-47260/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-47260
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-47260
- OSV: https://osv.dev/vulnerability/CVE-2026-47260

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-47260/
Summaries are generated and may contain mistakes; the official description above is the record.
