CVE-2026-47262 containerd image-triggered runtime DoS via unbounded group parsing
A maliciously crafted image can cause memory exhaustion in containerd, leading to a Denial of Service and disrupting container orchestration systems.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-47262?
CVE-2026-47262 is a medium-severity denial of service vulnerability in containerd, published on 1 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
containerd is an open-source container runtime. Versions prior to 1.7.33, 2.0.10, 2.1.9, 2.2.5 and 2.3.2, contain a vulnerability that allows a maliciously crafted image to cause a Denial of Service (DoS) condition. When creating a container from this image, memory exhaustion occurs, leading to an Out Of Memory (OOM) kill of the containerd process. This renders the container runtime API unavailable and can disrupt clients such as the Docker Engine or Kubernetes control-plane components. This issue has been fixed in versions 1.7.33, 2.0.10, 2.1.9, 2.2.5 and 2.3.2.
Weakness: CWE-400
Which versions are affected by CVE-2026-47262?
12 open source packages ship an affected version, including github.com/containerd/containerd/v2 and github.com/containerd/containerd. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
github.com/containerd/containerd/v2 Go | From 2.0.0 | 2.0.10, 2.1.9, 2.2.5, 2.3.2 |
github.com/containerd/containerd/v2 Go | From 2.0.0 | 2.0.10 |
github.com/containerd/containerd/v2 Go | From 2.0.0 | 2.0.10 |
github.com/containerd/containerd/v2 Go | From 2.1.0 | 2.1.9 |
github.com/containerd/containerd/v2 Go | From 2.1.0 | 2.1.9 |
github.com/containerd/containerd/v2 Go | From 2.2.0 | 2.2.5 |
6 more packages
github.com/containerd/containerd/v2 Go | From 2.2.0 | 2.2.5 |
github.com/containerd/containerd/v2 Go | From 2.3.0 | 2.3.2 |
github.com/containerd/containerd/v2 Go | From 2.3.0 | 2.3.2 |
github.com/containerd/containerd Go | From 1.7.0 | 1.7.33 |
github.com/containerd/containerd Go | From 1.7.0 | 1.7.33 |
github.com/containerd/containerd Go | From 1.7.0 | 1.7.33 |
Linux distribution packages (4)
kubernetes1.36 Red Hat:hummingbird:1 | All versions | 0:1.36.2-2.hum1 |
kubernetes1.36-client Red Hat:hummingbird:1 | All versions | 0:1.36.2-2.hum1 |
kubernetes1.36-kubeadm Red Hat:hummingbird:1 | All versions | 0:1.36.2-2.hum1 |
kubernetes1.36-systemd Red Hat:hummingbird:1 | All versions | 0:1.36.2-2.hum1 |
Products include Linuxfoundation Containerd.
How do I fix CVE-2026-47262?
Upgrade github.com/containerd/containerd/v2 to a fixed version for your release line: 2.0.10, 2.1.9, 2.2.5 or 2.3.2.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2026-47262 being exploited?
There is no known exploitation of CVE-2026-47262 in the wild and no public exploit code.
Other vulnerabilities in containerd
- CVE-2026-53488 containerd CRI — image-config `LABEL` flows to restart-monitor `binary://` logger: host-root command execution from an image pull
- CVE-2026-53492 containerd CRI checkpoint restore CDI annotation smuggling
- CVE-2026-53489 containerd: Arbitrary host CRI log file read via symlink following in CRI checkpoint restore
- CVE-2025-47290 Containerd vulnerable to host filesystem access during image unpack
- CVE-2026-46680 containerd user ID handling bypass allows runAsNonRoot evasion
Sources
Also known as AZL-90176, AZL-91782, BELL-CVE-2026-47262, CLEANSTART-2026-GE70813, CLEANSTART-2026-JO36112, CLEANSTART-2026-RF47243 and 209 more.