CVE-2026-47263 Discourse: Prevent webhook payload disclosure on event redelivery
Authenticated or anonymous users can read webhook payloads by enumerating sequential IDs due to missing access controls in event redelivery.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2026-47263?
CVE-2026-47263 is a medium-severity vulnerability in Discourse Discourse, published on 12 Jun 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
Discourse is an open-source discussion platform. From versions 2026.1.0-latest to before 2026.1.4, 2026.3.0-latest to before 2026.3.1, and 2026.4.0-latest to before 2026.4.1, the MessageBus.publish call for /web_hook_events/<id> in Jobs::RedeliverWebHookEvents did not pass group_ids, leaving the channel readable by any authenticated user (or anonymous user on instances where login_required is disabled). Webhook IDs are sequential integers and trivially enumerable. This issue has been patched in versions 2026.1.4, 2026.3.1, 2026.4.1, and 2026.5.0-latest.1.
Weakness: CWE-200
Which versions are affected by CVE-2026-47263?
1 open source package ship an affected version, including discourse. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
discourse Bitnami | From 2026.1.0 | 2026.1.4, 2026.3.1, 2026.4.1 |
Products include Discourse Discourse.
How do I fix CVE-2026-47263?
Upgrade discourse to a fixed version for your release line: 2026.1.4, 2026.3.1 or 2026.4.1.
Is CVE-2026-47263 being exploited?
There is no known exploitation of CVE-2026-47263 in the wild and no public exploit code.
Other vulnerabilities in Discourse Discourse
- CVE-2021-41163 RCE via malicious SNS subscription payload
- CVE-2022-36066 Discourse vulnerable to RCE via admins uploading maliciously zipped file
- CVE-2022-39356 Discourse user account takeover via email and invite link
- CVE-2023-22468 Discourse vulnerable to Cross-site Scripting in local oneboxes
- CVE-2026-27934 Discourse leaks private topic title and post excerpt via user action API endpoint
Sources
Also known as BIT-discourse-2026-47263, GHSA-wvrm-9v64-m96p.