# CVE-2026-47375: NocoDB: Postgres SQL Injection in Formula `ARRAYSORT`

> Authenticated users can inject SQL via the ARRAYSORT formula in Postgres-backed NocoDB instances, enabling arbitrary code execution and data access.

- **Severity:** Medium 6.0 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:L/I:L/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 23 Jun 2026
- **Updated:** 24 Jun 2026
- **Also known as:** GHSA-cxv7-gmmp-228p

## What is CVE-2026-47375?

CVE-2026-47375 is a medium-severity SQL injection vulnerability in nocodb, published on 23 Jun 2026. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

NocoDB is software for building databases as spreadsheets. Prior to 2026.04.1, an authenticated user with columnAdd permission on a Postgres-backed base can inject arbitrary SQL into the formula engine via the optional direction argument of ARRAYSORT(...). The value is unrestricted by formula validation and embedded into a knex.raw ORDER BY clause, executing during column creation and on every subsequent record read of the formula column. The vulnerability is specific to the Postgres mapping for ARRAYSORT in packages/nocodb/src/db/functionMappings/pg.ts. This vulnerability is fixed in 2026.04.1.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2026-47375?

2 open source packages ship an affected version, including nocodb.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `nocodb` | npm | All versions | 2026.04.1 |
| `nocodb` | npm | All versions | 2026.04.1 |

## How do I fix CVE-2026-47375?

Upgrade nocodb to 2026.04.1 or later.

## Is CVE-2026-47375 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-47375 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-47375 and fix it if it is affected.

What it is: CVE-2026-47375 is a medium-severity SQL injection vulnerability in nocodb, published on 23 Jun 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-47375 exists.

Affected packages and fixed versions:
- nocodb (npm): affected all versions; fixed in 2026.04.1
- nocodb (npm): affected all versions; fixed in 2026.04.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-47375/ (Markdown: https://insights.sbomify.com/CVE-2026-47375/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-47375
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-47375
- OSV: https://osv.dev/vulnerability/CVE-2026-47375

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-47375/
Summaries are generated and may contain mistakes; the official description above is the record.
