# CVE-2026-47376: NocoDB: Reflected Cross-Site Scripting via Password Reset Token

> Attackers can execute arbitrary JavaScript in the victim's browser via a crafted password reset link, potentially leading to account takeover.

- **Severity:** Medium 5.1 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 23 Jun 2026
- **Updated:** 24 Jun 2026
- **Also known as:** GHSA-6xcx-7qmg-vjfq

## What is CVE-2026-47376?

CVE-2026-47376 is a medium-severity cross-site scripting vulnerability in nocodb, published on 23 Jun 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

NocoDB is software for building databases as spreadsheets. Prior to 2026.04.1, the password-reset page rendered the URL token directly into a JavaScript string literal in a server-rendered EJS template. EJS <%= %> HTML-entity-encodes a fixed set of characters but does not escape single quotes or backslashes, so a crafted token could break out of the JS string context and execute attacker-controlled script in the NocoDB origin. Triggering required only that a victim follow a malicious password-reset link. This vulnerability is fixed in 2026.04.1.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-47376?

2 open source packages ship an affected version, including nocodb.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `nocodb` | npm | All versions | 2026.04.1 |
| `nocodb` | npm | All versions | 2026.04.1 |

## How do I fix CVE-2026-47376?

Upgrade nocodb to 2026.04.1 or later.

## Is CVE-2026-47376 being exploited?

There is no known exploitation of CVE-2026-47376 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-47376 and fix it if it is affected.

What it is: CVE-2026-47376 is a medium-severity cross-site scripting vulnerability in nocodb, published on 23 Jun 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-47376 in the wild and no public exploit code.

Affected packages and fixed versions:
- nocodb (npm): affected all versions; fixed in 2026.04.1
- nocodb (npm): affected all versions; fixed in 2026.04.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-47376/ (Markdown: https://insights.sbomify.com/CVE-2026-47376/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-47376
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-47376
- OSV: https://osv.dev/vulnerability/CVE-2026-47376

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-47376/
Summaries are generated and may contain mistakes; the official description above is the record.
