# CVE-2026-4738: Memory corruption in gdal

> An attacker can trigger heap corruption or remote code execution in GDAL via undefined behavior in the bundled zlib component.

- **Severity:** Critical 9.4 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H/E:A/S:P/AU:Y/R:U/V:C/RE:L/U:Amber`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 24 Mar 2026
- **Updated:** 24 Mar 2026
- **Also known as:** AZL-104972, BIT-gdal-2026-4738, DEBIAN-CVE-2026-4738, ECHO-c616-5e6d-4a3e, GHSA-hp6p-5qh5-w9fj, JLSEC-2026-288, UBUNTU-CVE-2026-4738

## What is CVE-2026-4738?

CVE-2026-4738 is a critical memory corruption vulnerability in OSGeo gdal, published on 24 Mar 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Improper Restriction of Operations within the Bounds of a Memory Buffer vulnerability in OSGeo gdal (frmts/zlib/contrib/infback9 modules). This vulnerability is associated with program files inftree9.C‎.

This issue affects gdal: before 3.11.0.

Weakness: CWE-119 (Improper Restriction of Operations within the Bounds of a Memory Buffer)

## Which versions are affected by CVE-2026-4738?

1 open source package ship an affected version, including gdal.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `gdal` | Bitnami | All versions | 3.11.0 |

## How do I fix CVE-2026-4738?

Upgrade gdal to 3.11.0 or later.

## Is CVE-2026-4738 being exploited?

There is no known exploitation of CVE-2026-4738 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-4738 and fix it if it is affected.

What it is: CVE-2026-4738 is a critical memory corruption vulnerability in OSGeo gdal, published on 24 Mar 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-4738 in the wild and no public exploit code.

Affected packages and fixed versions:
- gdal (Bitnami): affected all versions; fixed in 3.11.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-4738/ (Markdown: https://insights.sbomify.com/CVE-2026-4738/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-4738
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-4738
- OSV: https://osv.dev/vulnerability/CVE-2026-4738

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-4738/
Summaries are generated and may contain mistakes; the official description above is the record.
