# CVE-2026-47383: NocoDB: Stored Cross-Site Scripting via Row Comments

> Authenticated users can inject malicious scripts via row comments that execute in other users' browsers, potentially leading to session hijacking or data theft.

- **Severity:** High 7.4 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:P/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 23 Jun 2026
- **Updated:** 25 Jun 2026
- **Also known as:** GHSA-jf3g-4gwg-4h66

## What is CVE-2026-47383?

CVE-2026-47383 is a high-severity cross-site scripting vulnerability in nocodb, published on 23 Jun 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

NocoDB is software for building databases as spreadsheets. Prior to 2026.05.1, an authenticated commenter could store HTML in row comments that executed as script when other users hovered over the comment in the expanded form view. The comment write paths persisted the raw comment body with no server-side sanitisation; the expanded-form sidebar then rendered the stored body and fed its data-tooltip attribute to Tippy with allowHTML: true. Even when the editor stripped script tags at write time, attribute-level payloads re-entered the DOM as live HTML on hover. This vulnerability is fixed in 2026.05.1.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-47383?

2 open source packages ship an affected version, including nocodb.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `nocodb` | npm | All versions | 2026.05.1 |
| `nocodb` | npm | All versions | 2026.05.1 |

## How do I fix CVE-2026-47383?

Upgrade nocodb to 2026.05.1 or later.

## Is CVE-2026-47383 being exploited?

There is no known exploitation of CVE-2026-47383 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-47383 and fix it if it is affected.

What it is: CVE-2026-47383 is a high-severity cross-site scripting vulnerability in nocodb, published on 23 Jun 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-47383 in the wild and no public exploit code.

Affected packages and fixed versions:
- nocodb (npm): affected all versions; fixed in 2026.05.1
- nocodb (npm): affected all versions; fixed in 2026.05.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-47383/ (Markdown: https://insights.sbomify.com/CVE-2026-47383/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-47383
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-47383
- OSV: https://osv.dev/vulnerability/CVE-2026-47383

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-47383/
Summaries are generated and may contain mistakes; the official description above is the record.
