# CVE-2026-47385: NocoDB: Path Traversal via SQLite Source Filename

> Authenticated users can exploit path traversal in SQLite source filenames to read or overwrite arbitrary files on the NocoDB host.

- **Severity:** Medium 5.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 23 Jun 2026
- **Updated:** 24 Jun 2026
- **Also known as:** GHSA-wvqj-9wv4-7ff5

## What is CVE-2026-47385?

CVE-2026-47385 is a medium-severity path traversal vulnerability in nocodb, published on 23 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

NocoDB is software for building databases as spreadsheets. Prior to 2026.05.1, an authenticated user with base-create permission can attach a SQLite source pointing at an arbitrary file on the NocoDB host, including NocoDB's own internal databases. The SQLite client and the base/integration create services accepted a caller-supplied filename and passed it to fs.exists and fs.open('w') without restricting the location. A user could point a source at noco.db, at a tenant database under nc_minimal_dbs/, or at any writable path the NocoDB process can reach, and then read or overwrite its contents through the regular table APIs.This vulnerability is fixed in 2026.05.1.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2026-47385?

2 open source packages ship an affected version, including nocodb.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `nocodb` | npm | All versions | 2026.05.1 |
| `nocodb` | npm | All versions | 2026.05.1 |

## How do I fix CVE-2026-47385?

Upgrade nocodb to 2026.05.1 or later.

## Is CVE-2026-47385 being exploited?

There is no known exploitation of CVE-2026-47385 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-47385 and fix it if it is affected.

What it is: CVE-2026-47385 is a medium-severity path traversal vulnerability in nocodb, published on 23 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-47385 in the wild and no public exploit code.

Affected packages and fixed versions:
- nocodb (npm): affected all versions; fixed in 2026.05.1
- nocodb (npm): affected all versions; fixed in 2026.05.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-47385/ (Markdown: https://insights.sbomify.com/CVE-2026-47385/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-47385
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-47385
- OSV: https://osv.dev/vulnerability/CVE-2026-47385

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-47385/
Summaries are generated and may contain mistakes; the official description above is the record.
