# CVE-2026-47387: NocoDB: Stored Cross-Site Scripting via Form View Redirect URL

> An editor can inject a javascript URL into a form redirect, allowing execution in the victim's browser to steal session tokens.

- **Severity:** High 8.4 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:A/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 23 Jun 2026
- **Updated:** 24 Jun 2026
- **Also known as:** GHSA-hj85-ph9q-78jg

## What is CVE-2026-47387?

CVE-2026-47387 is a high-severity cross-site scripting vulnerability in nocodb, published on 23 Jun 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

NocoDB is software for building databases as spreadsheets. Prior to 2026.05.1, the shared form-view submit handler (packages/nc-gui/composables/useSharedFormViewStore.ts) in NocoDB writes the form's redirect_url to window.location.href after a same-host check that does not validate the URL scheme. A user with editor role (or above) on any base can plant a javascript: URL in the form's redirect_url; when an authenticated viewer opens the share-link and submits the form, the payload executes in the NocoDB origin and can read the session token from localStorage["nocodb-gui-v2"]. This vulnerability is fixed in 2026.05.1.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-47387?

2 open source packages ship an affected version, including nocodb.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `nocodb` | npm | All versions | 2026.05.1 |
| `nocodb` | npm | All versions | 2026.05.1 |

## How do I fix CVE-2026-47387?

Upgrade nocodb to 2026.05.1 or later.

## Is CVE-2026-47387 being exploited?

There is no known exploitation of CVE-2026-47387 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-47387 and fix it if it is affected.

What it is: CVE-2026-47387 is a high-severity cross-site scripting vulnerability in nocodb, published on 23 Jun 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-47387 in the wild and no public exploit code.

Affected packages and fixed versions:
- nocodb (npm): affected all versions; fixed in 2026.05.1
- nocodb (npm): affected all versions; fixed in 2026.05.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-47387/ (Markdown: https://insights.sbomify.com/CVE-2026-47387/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-47387
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-47387
- OSV: https://osv.dev/vulnerability/CVE-2026-47387

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-47387/
Summaries are generated and may contain mistakes; the official description above is the record.
