# CVE-2026-47390: PraisonAI spider_tools SSRF protection bypass via alternate loopback host encodings

> Attackers can bypass SSRF protections in PraisonAI spider tools using alternate loopback encodings to access internal services.

- **Severity:** Medium 5.5 (`CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 21 Jul 2026
- **Updated:** 22 Jul 2026
- **Also known as:** GHSA-5c6w-wwfq-7qqm, PYSEC-2026-2902, PYSEC-2026-2941

## What is CVE-2026-47390?

CVE-2026-47390 is a medium-severity server-side request forgery vulnerability in MervinPraison PraisonAI, published on 21 Jul 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

PraisonAI is a multi-agent teams system. Prior to version 4.6.40 of PraisonAI, corresponding to version 1.6.40 of praisonaiagents, `spider_tools` URL validation can be bypassed using alternate loopback host encodings. The tool contains a URL validation function intended to block local or unsafe targets before fetching attacker-controlled URLs. However, the validation only blocks a small set of exact host strings such as `localhost` and `127.0.0.1`. It does not normalize hostnames, resolve DNS, parse numeric IPv4 variants, or validate the final resolved IP address before making the request. As a result, certain URLs may bypass the protection and still reach loopback services. After the weak validation passes, `scrape_page()` calls `requests.Session.get()` on the attacker-controlled URL. This allows an attacker who can influence URLs passed to `scrape_page`, `crawl`, or `extract_text` to induce SSRF requests against loopback-only services. This is a server-side request forgery protection bypass. PraisonAI version 4.6.40 and praisonaiagents version 1.6.40 contain a patch.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2026-47390?

6 open source packages ship an affected version, including praisonaiagents, PraisonAI and praisonai.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `praisonaiagents` | PyPI | All versions | 1.6.40 |
| `praisonaiagents` | PyPI | All versions | 1.6.40 |
| `praisonaiagents` | PyPI | All versions | 1.6.40 |
| `PraisonAI` | PyPI | All versions | 4.6.40 |
| `praisonai` | PyPI | All versions | 4.6.40 |
| `praisonai` | PyPI | All versions | 4.6.40 |

## How do I fix CVE-2026-47390?

Upgrade praisonaiagents to 1.6.40 or later.

## Is CVE-2026-47390 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-47390 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-47390 and fix it if it is affected.

What it is: CVE-2026-47390 is a medium-severity server-side request forgery vulnerability in MervinPraison PraisonAI, published on 21 Jul 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-47390 exists.

Affected packages and fixed versions:
- praisonaiagents (PyPI): affected all versions; fixed in 1.6.40
- praisonaiagents (PyPI): affected all versions; fixed in 1.6.40
- praisonaiagents (PyPI): affected all versions; fixed in 1.6.40
- PraisonAI (PyPI): affected all versions; fixed in 4.6.40
- praisonai (PyPI): affected all versions; fixed in 4.6.40
- praisonai (PyPI): affected all versions; fixed in 4.6.40

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-47390/ (Markdown: https://insights.sbomify.com/CVE-2026-47390/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-47390
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-47390
- OSV: https://osv.dev/vulnerability/CVE-2026-47390

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-47390/
Summaries are generated and may contain mistakes; the official description above is the record.
