# CVE-2026-47407: PraisonAI Platform has a cross-workspace IDOR + member-role privilege escalation

> Attackers can access cross-tenant resources and escalate privileges to admin due to missing authorization checks in PraisonAI Platform.

- **Severity:** Critical 9.4 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 21 Jul 2026
- **Updated:** 22 Jul 2026
- **Also known as:** GHSA-h8q5-cp56-rr65, PYSEC-2026-482

## What is CVE-2026-47407?

CVE-2026-47407 is a critical missing authorization vulnerability in MervinPraison praisonai-platform, published on 21 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

PraisonAI Platform is the platform layer for the PraisonAI multi-agent teams system. Prior to version 0.1.4, the Platform server exposes resources under `/api/v1/workspaces/{workspace_id}/...` and protects them with a `require_workspace_member(workspace_id)` FastAPI dependency. The dependency only checks that the caller is a member of the workspace_id in the URL prefix. The route handlers then look up the inner resource (`agent_id`, `issue_id`, `project_id`, `label_id`, `comment_id`, `dependency_id`) by primary key alone. The resource's own `workspace_id` is never compared to the URL's `workspace_id`. A user can therefore put their own workspace in the URL prefix and any other workspace's resource ID in the path. The auth check passes, since they really are a member of the prefix workspace. The service then returns the cross-tenant resource for read, update, or delete. There is a second bug in the member-management routes (`add_member`, `update_member_role`, `remove_member`, `update_workspace`, `delete_workspace`). Each one inherits the default `min_role="member"` from `require_workspace_member`. Any basic member can therefore promote themselves to admin or owner, demote or remove other members, and delete the workspace. The role hierarchy exists in the schema but is not enforced. Registration is open at `/api/v1/auth/register` with no email verification. The default server bind is `0.0.0.0:8000` (`python -m praisonai_platform`). One curl from any unauthenticated network position is enough to bootstrap into the system. PraisonAI Platform version 0.1.4 patches the issue.

Weakness: CWE-639 (Authorization Bypass Through User-Controlled Key), CWE-863 (Incorrect Authorization), CWE-269 (Improper Privilege Management)

## Which versions are affected by CVE-2026-47407?

3 open source packages ship an affected version, including praisonai-platform.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `praisonai-platform` | PyPI | All versions | 0.1.4 |
| `praisonai-platform` | PyPI | All versions | 0.1.4 |
| `praisonai-platform` | PyPI | All versions | 0.1.4 |

## How do I fix CVE-2026-47407?

Upgrade praisonai-platform to 0.1.4 or later.

## Is CVE-2026-47407 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-47407 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-47407 and fix it if it is affected.

What it is: CVE-2026-47407 is a critical missing authorization vulnerability in MervinPraison praisonai-platform, published on 21 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-47407 exists.

Affected packages and fixed versions:
- praisonai-platform (PyPI): affected all versions; fixed in 0.1.4
- praisonai-platform (PyPI): affected all versions; fixed in 0.1.4
- praisonai-platform (PyPI): affected all versions; fixed in 0.1.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-47407/ (Markdown: https://insights.sbomify.com/CVE-2026-47407/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-47407
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-47407
- OSV: https://osv.dev/vulnerability/CVE-2026-47407

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-47407/
Summaries are generated and may contain mistakes; the official description above is the record.
