{"answers":{"affected":"2 open source packages ship an affected version, including org.openidentityplatform.openam:openam-scripting.","exploited":"There is no known exploitation of CVE-2026-47424 in the wild and no public exploit code.","fix":"Upgrade org.openidentityplatform.openam:openam-scripting to 16.1.1 or later.","what":"CVE-2026-47424 is a high-severity code injection vulnerability in OpenIdentityPlatform OpenAM, published on 15 Sep 2026. An attacker needs administrator access to exploit it, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-47424 and fix it if it is affected.\n\nWhat it is: CVE-2026-47424 is a high-severity code injection vulnerability in OpenIdentityPlatform OpenAM, published on 15 Sep 2026. An attacker needs administrator access to exploit it, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-47424 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.openidentityplatform.openam:openam-scripting (Maven): affected all versions; fixed in 16.1.1\n- org.openidentityplatform.openam:openam-scripting (Maven): affected all versions; fixed in 16.1.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-47424/ (Markdown: https://insights.sbomify.com/CVE-2026-47424/index.md)","id":"CVE-2026-47424","markdown":"https://insights.sbomify.com/CVE-2026-47424/index.md","name":"CVE-2026-47424","record":{"aliases":["GHSA-69j4-qvqr-hpw3","UBUNTU-CVE-2026-47424"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["code_execution","privilege_escalation"],"network_reachable":"yes","non_default_config":false,"product_category":"OpenAM access management","requires_auth":"high_privilege","summary":"Authenticated script authors can escape the Groovy sandbox to execute OS commands, compromising the JVM and all realms.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:P/PR:H/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-693","name":"Protection Mechanism Failure"}],"description":"Open Access Management (OpenAM) is an access management solution. Prior to 16.1.1, GroovySandboxValueFilter permits an authenticated server-side script author to escape the scripting sandbox despite the default class allow and deny lists. A user such as a sub-realm RealmAdmin who can create or edit a script in an executed context can invoke operating-system commands as the OpenAM application server account, crossing the realm-scoped administration boundary and compromising the JVM and every realm it serves. This issue is fixed in version 16.1.1.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"OpenAM Authenticated RCE via Groovy Sandbox Escape","id":"CVE-2026-47424","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"code_injection","year":"2026"},"n_packages":2,"n_references":3,"next":{"headline":"Rattler vulnerable to entry-point path traversal in noarch:python install (arbitrary file write)","id":"CVE-2026-47425"},"packages":[{"ecosystem":"Maven","fixed":["16.1.1"],"introduced":["0"],"last_affected":[],"package":"org.openidentityplatform.openam:openam-scripting","purl":null,"source":"GHSA-69j4-qvqr-hpw3"},{"ecosystem":"Maven","fixed":["16.1.1"],"introduced":["0"],"last_affected":[],"package":"org.openidentityplatform.openam:openam-scripting","purl":"pkg:maven/org.openidentityplatform.openam/openam-scripting","source":"GHSA-69j4-qvqr-hpw3"}],"prev":{"headline":"DOMPurify XSS via `selectedcontent` re-clone","id":"CVE-2026-47423"},"products":["OpenAM"],"published":"2026-09-15","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-09-15","vendors":["OpenIdentityPlatform"]},"summary":"Authenticated script authors can escape the Groovy sandbox to execute OS commands, compromising the JVM and all realms.","url":"https://insights.sbomify.com/CVE-2026-47424/"}