# CVE-2026-47424: OpenAM Authenticated RCE via Groovy Sandbox Escape

> Authenticated script authors can escape the Groovy sandbox to execute OS commands, compromising the JVM and all realms.

- **Severity:** High 7.5 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:H/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Sep 2026
- **Updated:** 15 Sep 2026
- **Also known as:** GHSA-69j4-qvqr-hpw3, UBUNTU-CVE-2026-47424

## What is CVE-2026-47424?

CVE-2026-47424 is a high-severity code injection vulnerability in OpenIdentityPlatform OpenAM, published on 15 Sep 2026. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Open Access Management (OpenAM) is an access management solution. Prior to 16.1.1, GroovySandboxValueFilter permits an authenticated server-side script author to escape the scripting sandbox despite the default class allow and deny lists. A user such as a sub-realm RealmAdmin who can create or edit a script in an executed context can invoke operating-system commands as the OpenAM application server account, crossing the realm-scoped administration boundary and compromising the JVM and every realm it serves. This issue is fixed in version 16.1.1.

Weakness: CWE-693 (Protection Mechanism Failure)

## Which versions are affected by CVE-2026-47424?

2 open source packages ship an affected version, including org.openidentityplatform.openam:openam-scripting.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.openidentityplatform.openam:openam-scripting` | Maven | All versions | 16.1.1 |
| `org.openidentityplatform.openam:openam-scripting` | Maven | All versions | 16.1.1 |

## How do I fix CVE-2026-47424?

Upgrade org.openidentityplatform.openam:openam-scripting to 16.1.1 or later.

## Is CVE-2026-47424 being exploited?

There is no known exploitation of CVE-2026-47424 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-47424 and fix it if it is affected.

What it is: CVE-2026-47424 is a high-severity code injection vulnerability in OpenIdentityPlatform OpenAM, published on 15 Sep 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-47424 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.openidentityplatform.openam:openam-scripting (Maven): affected all versions; fixed in 16.1.1
- org.openidentityplatform.openam:openam-scripting (Maven): affected all versions; fixed in 16.1.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-47424/ (Markdown: https://insights.sbomify.com/CVE-2026-47424/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-47424
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-47424
- OSV: https://osv.dev/vulnerability/CVE-2026-47424

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-47424/
Summaries are generated and may contain mistakes; the official description above is the record.
