# CVE-2026-47426: OpenAM OAuth Client Impersonation via JWKS Resolver Cache

> Attackers can impersonate other OAuth clients and mint tokens by exploiting a cache binding flaw in OpenAM's JWKS resolver.

- **Severity:** High 7.6 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Sep 2026
- **Updated:** 17 Sep 2026
- **Also known as:** GHSA-f2cx-463q-7m2c, UBUNTU-CVE-2026-47426

## What is CVE-2026-47426?

CVE-2026-47426 is a high-severity authentication bypass vulnerability in OpenIdentityPlatform OpenAM, published on 15 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Open Access Management (OpenAM) is an access management solution. Prior to 16.1.1, the private_key_jwt client authentication path uses ClientJwksResolverCache without reliably binding a cached jwks_uri resolver and verified assertion to the expected clientID in ClientCredentialsReader. An attacker controlling any registered client with published keys, including one obtained through open dynamic registration when enabled, can authenticate as another client whose keys are exposed through jwks_uri and mint tokens in that client's name across realms in the same OpenAM process. This issue is fixed in version 16.1.1.

Weakness: CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2026-47426?

2 open source packages ship an affected version, including org.openidentityplatform.openam:openam-oauth2.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.openidentityplatform.openam:openam-oauth2` | Maven | All versions | 16.1.1 |
| `org.openidentityplatform.openam:openam-oauth2` | Maven | All versions | 16.1.1 |

## How do I fix CVE-2026-47426?

Upgrade org.openidentityplatform.openam:openam-oauth2 to 16.1.1 or later.

## Is CVE-2026-47426 being exploited?

There is no known exploitation of CVE-2026-47426 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-47426 and fix it if it is affected.

What it is: CVE-2026-47426 is a high-severity authentication bypass vulnerability in OpenIdentityPlatform OpenAM, published on 15 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-47426 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.openidentityplatform.openam:openam-oauth2 (Maven): affected all versions; fixed in 16.1.1
- org.openidentityplatform.openam:openam-oauth2 (Maven): affected all versions; fixed in 16.1.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-47426/ (Markdown: https://insights.sbomify.com/CVE-2026-47426/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-47426
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-47426
- OSV: https://osv.dev/vulnerability/CVE-2026-47426

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-47426/
Summaries are generated and may contain mistakes; the official description above is the record.
