# CVE-2026-47427: GitHub MCP Server: Nil Pointer Dereference DoS in completion/complete Handler

> Unauthenticated attackers can crash the GitHub MCP Server by sending a malformed completion request, causing a denial of service.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 28 Jul 2026
- **Updated:** 28 Jul 2026
- **Also known as:** GHSA-w4q6-qw23-4rg7, GO-2026-6118

## What is CVE-2026-47427?

CVE-2026-47427 is a high-severity vulnerability in github-mcp-server, published on 28 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

GitHub MCP Server is GitHub's official MCP Server. Prior to 1.1.0, the CompletionsHandler function in pkg/github/server.go accesses params.Ref without first checking whether it is nil, so a completion/complete request with a missing or empty ref field triggers a nil pointer dereference and a Go runtime panic; because the crash occurs before any authentication or token validation, any unauthenticated client able to send JSON-RPC messages can crash the server, resulting in a complete denial of service. This issue is fixed in version 1.1.0.

Weakness: CWE-476 (NULL Pointer Dereference)

## Which versions are affected by CVE-2026-47427?

3 open source packages ship an affected version, including github.com/github/github-mcp-server. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/github/github-mcp-server` | Go | All versions | 1.1.0 |
| `github.com/github/github-mcp-server` | Go | All versions | 1.1.0 |
| `github.com/github/github-mcp-server` | Go | All versions | 1.1.0 |

Products: Github Mcp Server.

## How do I fix CVE-2026-47427?

Upgrade github.com/github/github-mcp-server to 1.1.0 or later.

## Is CVE-2026-47427 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-47427 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-47427 and fix it if it is affected.

What it is: CVE-2026-47427 is a high-severity vulnerability in github-mcp-server, published on 28 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-47427 exists.

Affected packages and fixed versions:
- github.com/github/github-mcp-server (Go): affected all versions; fixed in 1.1.0
- github.com/github/github-mcp-server (Go): affected all versions; fixed in 1.1.0
- github.com/github/github-mcp-server (Go): affected all versions; fixed in 1.1.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-47427/ (Markdown: https://insights.sbomify.com/CVE-2026-47427/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-47427
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-47427
- OSV: https://osv.dev/vulnerability/CVE-2026-47427

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-47427/
Summaries are generated and may contain mistakes; the official description above is the record.
