# CVE-2026-47430: Cordova Plugin InAppBrowser: iOS: Arbitrary Cordova callback IDs can be dispatched without validation from InAppBrowser WebViews.

> Attackers can spoof Cordova plugin results by dispatching arbitrary callback IDs from InAppBrowser WebViews, potentially accessing sensitive data or modifying app state.

- **Severity:** Critical 9.5 (`CVSS:4.0/AV:N/AC:H/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 Jun 2026
- **Updated:** 8 Jun 2026
- **Also known as:** GHSA-q42j-x8rq-pjg6

## What is CVE-2026-47430?

CVE-2026-47430 is a critical missing authorization vulnerability in Apache Software Foundation Cordova Plugin InAppBrowser, published on 8 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

## Summary

The iOS implementation of `cordova-plugin-inappbrowser` passes the `id` field from a `WKScriptMessage` body to `commandDelegate sendPluginResult:callbackId:` with no format validation (`CDVWKInAppBrowser.m:560–574`). Any web content loaded inside the InAppBrowser can fire any pending Cordova callback in the host app by posting a message whose `id` field is a guessable or enumerated callback identifier. An attack abusing this weakness must be tailored to the specific plugins and callback IDs the host app uses. Though an attacker with knowledge of common Cordova plugin configurations could craft reusable payloads targeting widely-adopted plugins.

## Impact

An unauthenticated remote attacker who controls content displayed in the InAppBrowser — via a URL the app opens (OAuth redirect, marketing link, deep-link target) or a network interception — can call `window.webkit.messageHandlers.cordova_iab.postMessage({id: '<victim-callback-id>', d: '...'})` to fire callbacks belonging to any other installed Cordova plugin (Camera, Contacts, File, Geolocation). Cordova callback IDs follow the predictable format `<PluginName><sequential-integer>`, making enumeration feasible. Successful exploitation allows the attacker to spoof plugin results across trust boundaries — for example, injecting a forged camera approval, a fabricated contacts list, or a crafted file-read response.

This issue affects Cordova Plugin InAppBrowser: from 3.1.0 through 6.0.0.

Users are recommended to upgrade to version 6.0.1, which fixes the issue.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2026-47430?

2 open source packages ship an affected version, including cordova-plugin-inappbrowser. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `cordova-plugin-inappbrowser` | npm | All versions | 6.0.1 |
| `cordova-plugin-inappbrowser` | npm | All versions | 6.0.1 |

Products: Apache Cordova Inappbrowser.

## How do I fix CVE-2026-47430?

Upgrade cordova-plugin-inappbrowser to 6.0.1 or later.

## Is CVE-2026-47430 being exploited?

There is no known exploitation of CVE-2026-47430 in the wild and no public exploit code.

## Other vulnerabilities in Apache Software Foundation Cordova Plugin InAppBrowser

- [CVE-2019-0219](https://insights.sbomify.com/CVE-2019-0219/): Privilege Escalation in cordova-plugin-inappbrowser (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-47430 and fix it if it is affected.

What it is: CVE-2026-47430 is a critical missing authorization vulnerability in Apache Software Foundation Cordova Plugin InAppBrowser, published on 8 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-47430 in the wild and no public exploit code.

Affected packages and fixed versions:
- cordova-plugin-inappbrowser (npm): affected all versions; fixed in 6.0.1
- cordova-plugin-inappbrowser (npm): affected all versions; fixed in 6.0.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-47430/ (Markdown: https://insights.sbomify.com/CVE-2026-47430/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-47430
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-47430
- OSV: https://osv.dev/vulnerability/CVE-2026-47430

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-47430/
Summaries are generated and may contain mistakes; the official description above is the record.
