# CVE-2026-47664: Pathling: $import-pnp operation enables authenticated SSRF, credential leakage, and warehouse data poisoning

> Authenticated attackers can exploit the $import-pnp operation to perform SSRF, leak credentials, and poison warehouse data by bypassing source allowlists.

- **Severity:** High 8.6 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 7 Aug 2026
- **Updated:** 10 Aug 2026
- **Also known as:** GHSA-69wc-hrxh-5528

## What is CVE-2026-47664?

CVE-2026-47664 is a high-severity server-side request forgery vulnerability in aehrc pathling, published on 7 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Pathling is a set of tools that make it easier to use FHIR and clinical terminology within health data analytics. Prior to version 2.0.0 of Pathling Server, the `$import-pnp` operation in Pathling Server accepts a caller-supplied `exportUrl` and uses it as the remote FHIR Bulk Export endpoint without constraining it to a trusted source. When PNP credentials are configured, Pathling builds a credentialed bulk-export client targeting the caller-chosen host, downloads manifest-selected files, and then reclassifies those staged files as trusted local `file://` imports - bypassing the configured `allowableSources` allowlist that protects the ordinary `$import` operation. This is fixed in Pathling Server 2.0.0. As a workaround, disable the `$import-pnp` operation (`pathling.operations.importPnpEnabled=false`) or do not configure PNP credentials.

Weakness: CWE-918 (Server-Side Request Forgery), CWE-345 (Insufficient Verification of Data Authenticity), CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2026-47664?


## How do I fix CVE-2026-47664?

No fix has been published for CVE-2026-47664 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-47664 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-47664 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-47664 and fix it if it is affected.

What it is: CVE-2026-47664 is a high-severity server-side request forgery vulnerability in aehrc pathling, published on 7 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-47664 exists.

Affected product: aehrc pathling. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-47664/ (Markdown: https://insights.sbomify.com/CVE-2026-47664/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-47664
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-47664
- OSV: https://osv.dev/vulnerability/CVE-2026-47664

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-47664/
Summaries are generated and may contain mistakes; the official description above is the record.
