CVE-2026-47670 DbGate Vulnerable to Authenticated Remote Code Execution via loadReader functionName code injection

Critical 9.4 Published Updated

Authenticated attackers can execute arbitrary OS commands as root in DbGate by exploiting unsanitized input in the loadReader endpoint.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-47670?

CVE-2026-47670 is a critical code injection vulnerability in dbgate, published on 23 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

DbGate is cross-platform database manager. Versions 7.1.8 and prior are vulnerable to authenticated Remote Code Execution (RCE). Any user with valid DbGate credentials can execute arbitrary OS commands as root by exploiting an unsanitized `functionName` parameter in the `/runners/load-reader` endpoint. The `require = null` mitigation is trivially bypassed via dynamic `import()`. Version 7.1.9 contains a patch.

Weakness: CWE-78, CWE-77

Which versions are affected by CVE-2026-47670?

2 open source packages ship an affected version, including dbgate-api.

PackageAffectedFixed in
dbgate-api npmAll versions7.1.9
dbgate-api npmAll versions7.1.9

How do I fix CVE-2026-47670?

Upgrade dbgate-api to 7.1.9 or later.

Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.

Is CVE-2026-47670 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-47670 exists.

Public exploit code: 1 Nuclei template and 1 proofs of concept on GitHub.

Sources

Also known as GHSA-wm5r-5qp3-5vxf.

Is CVE-2026-47670 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free