# CVE-2026-47670: DbGate Vulnerable to Authenticated Remote Code Execution via loadReader functionName code injection

> Authenticated attackers can execute arbitrary OS commands as root in DbGate by exploiting unsanitized input in the loadReader endpoint.

- **Severity:** Critical 9.4 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 23 Jul 2026
- **Updated:** 24 Jul 2026
- **Also known as:** GHSA-wm5r-5qp3-5vxf

## What is CVE-2026-47670?

CVE-2026-47670 is a critical code injection vulnerability in dbgate, published on 23 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

DbGate is cross-platform database manager. Versions 7.1.8 and prior are vulnerable to authenticated Remote Code Execution (RCE). Any user with valid DbGate credentials can execute arbitrary OS commands as root by exploiting an unsanitized `functionName` parameter in the `/runners/load-reader` endpoint. The `require = null` mitigation is trivially bypassed via dynamic `import()`. Version 7.1.9 contains a patch.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command), CWE-77 (Improper Neutralization of Special Elements used in a Command)

## Which versions are affected by CVE-2026-47670?

2 open source packages ship an affected version, including dbgate-api.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `dbgate-api` | npm | All versions | 7.1.9 |
| `dbgate-api` | npm | All versions | 7.1.9 |

## How do I fix CVE-2026-47670?

Upgrade dbgate-api to 7.1.9 or later.

## Is CVE-2026-47670 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-47670 exists.

Public exploit code:

- Authenticated Remote Code Execution via loadReader functionName code injection in DbGate (github_poc): https://github.com/error-inside/CVE-2026-47670
- DbGate - Remote Code Execution via Dynamic Import Bypass (nuclei): http/cves/2026/CVE-2026-47670.yaml

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-47670 and fix it if it is affected.

What it is: CVE-2026-47670 is a critical code injection vulnerability in dbgate, published on 23 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-47670 exists.

Affected packages and fixed versions:
- dbgate-api (npm): affected all versions; fixed in 7.1.9
- dbgate-api (npm): affected all versions; fixed in 7.1.9

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-47670/ (Markdown: https://insights.sbomify.com/CVE-2026-47670/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-47670
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-47670
- OSV: https://osv.dev/vulnerability/CVE-2026-47670

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-47670/
Summaries are generated and may contain mistakes; the official description above is the record.
