CVE-2026-47680 Source controller: Improper path handling allows traversal
- Exploited in the wild
- Not known
- Fix
- Available
What is CVE-2026-47680?
CVE-2026-47680 is a medium-severity vulnerability in fluxcd source-controller, published on 8 Sep 2026.
Official description
The source-controller is a Kubernetes operator, specialised in artifacts acquisition from external sources such as Git, OCI, Helm repositories and S3-compatible buckets. In versions 0.0.17 through 1.8.4, an actor with the ability to influence the contents of a bucket referenced by a `Bucket` resource can cause source-controller to write fetched object data to paths outside the per-reconciliation working directory. The corruption surface is bounded by source-controller's own and downstream Flux controllers' digest verification: source-controller verifies stored artifact digests during reconciliation and rebuilds on divergence; consumers (kustomize-controller, helm-controller) verify the digest of fetched artifacts and reject mismatches. These checks prevent a manipulated artifact from reaching the cluster, but an attacker can still write files anywhere the source-controller pod has permission to write. Separately, a user with permission to create or update `GitRepository` resources can cause source-controller to test for the existence of paths outside the cloned repository. Because the result is exposed via the resource's status, this allows limited enumeration of file paths on the controller pod. This surface exists only on source-controller v1.6.0 and later, where the sparse-checkout feature was introduced. This vulnerability was fixed in source-controller v1.8.5. There is no in-product workaround. Users should upgrade to a patched version. As a defense-in-depth measure for the GitRepository sparse-checkout surface, a `ValidatingAdmissionPolicy` (or a third-party policy engine such as Kyverno or OPA Gatekeeper) can be deployed to reject `GitRepository` resources whose `.spec.sparseCheckout` entries contain `..` or absolute path segments.
Weakness: CWE-23
Which versions are affected by CVE-2026-47680?
3 open source packages ship an affected version, including github.com/fluxcd/source-controller.
| Package | Affected | Fixed in |
|---|---|---|
github.com/fluxcd/source-controller Go | From 0.0.17 | 1.8.5 |
github.com/fluxcd/source-controller Go | From 0.0.17 | 1.8.5 |
github.com/fluxcd/source-controller Go | From 0.0.17 | 1.8.5 |
How do I fix CVE-2026-47680?
Upgrade github.com/fluxcd/source-controller to 1.8.5 or later.
Is CVE-2026-47680 being exploited?
There is no known exploitation of CVE-2026-47680 in the wild and no public exploit code.
Sources
Also known as GHSA-jjrm-hr5f-673x, GO-2026-5472.