# CVE-2026-47680: Source controller: Improper path handling allows traversal


- **Severity:** Medium 5.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:L/VA:L/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 8 Sep 2026
- **Updated:** 9 Sep 2026
- **Also known as:** GHSA-jjrm-hr5f-673x, GO-2026-5472

## What is CVE-2026-47680?

CVE-2026-47680 is a medium-severity vulnerability in fluxcd source-controller, published on 8 Sep 2026. 

### Official description

The source-controller is a Kubernetes operator, specialised in artifacts acquisition from external sources such as Git, OCI, Helm repositories and S3-compatible buckets. In versions 0.0.17 through 1.8.4, an actor with the ability to influence the contents of a bucket referenced by a `Bucket` resource can cause source-controller to write fetched object data to paths outside the per-reconciliation working directory. The corruption surface is bounded by source-controller's own and downstream Flux controllers' digest verification: source-controller verifies stored artifact digests during reconciliation and rebuilds on divergence; consumers (kustomize-controller, helm-controller) verify the digest of fetched artifacts and reject mismatches. These checks prevent a manipulated artifact from reaching the cluster, but an attacker can still write files anywhere the source-controller pod has permission to write. Separately, a user with permission to create or update `GitRepository` resources can cause source-controller to test for the existence of paths outside the cloned repository. Because the result is exposed via the resource's status, this allows limited enumeration of file paths on the controller pod. This surface exists only on source-controller v1.6.0 and later, where the sparse-checkout feature was introduced. This vulnerability was fixed in source-controller v1.8.5. There is no in-product workaround. Users should upgrade to a patched version. As a defense-in-depth measure for the GitRepository sparse-checkout surface, a `ValidatingAdmissionPolicy` (or a third-party policy engine such as Kyverno or OPA Gatekeeper) can be deployed to reject `GitRepository` resources whose `.spec.sparseCheckout` entries contain `..` or absolute path segments.

Weakness: CWE-23 (Relative Path Traversal)

## Which versions are affected by CVE-2026-47680?

3 open source packages ship an affected version, including github.com/fluxcd/source-controller.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/fluxcd/source-controller` | Go | From 0.0.17 | 1.8.5 |
| `github.com/fluxcd/source-controller` | Go | From 0.0.17 | 1.8.5 |
| `github.com/fluxcd/source-controller` | Go | From 0.0.17 | 1.8.5 |

## How do I fix CVE-2026-47680?

Upgrade github.com/fluxcd/source-controller to 1.8.5 or later.

## Is CVE-2026-47680 being exploited?

There is no known exploitation of CVE-2026-47680 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-47680 and fix it if it is affected.

What it is: CVE-2026-47680 is a medium-severity vulnerability in fluxcd source-controller, published on 8 Sep 2026. 
Exploitation: There is no known exploitation of CVE-2026-47680 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/fluxcd/source-controller (Go): affected from 0.0.17; fixed in 1.8.5
- github.com/fluxcd/source-controller (Go): affected from 0.0.17; fixed in 1.8.5
- github.com/fluxcd/source-controller (Go): affected from 0.0.17; fixed in 1.8.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-47680/ (Markdown: https://insights.sbomify.com/CVE-2026-47680/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-47680
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-47680
- OSV: https://osv.dev/vulnerability/CVE-2026-47680

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-47680/
Summaries are generated and may contain mistakes; the official description above is the record.
