# CVE-2026-47684: Sync-in Server: SSRF protection bypass via IPv4-mapped IPv6 addresses in regExpPrivateIP

> Attackers can bypass SSRF protections in Sync-in Server by using IPv4-mapped IPv6 addresses to access internal resources.

- **Severity:** High 7.7 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 Jun 2026
- **Updated:** 16 Jun 2026
- **Also known as:** GHSA-q4x5-8cj6-52wg

## What is CVE-2026-47684?

CVE-2026-47684 is a high-severity server-side request forgery vulnerability in Sync-in server, published on 16 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Sync-in Server is a secure, open-source platform for file storage, sharing, collaboration, and syncing. Prior to version 2.3.0, the private IP blocklist regex used in the URL download feature does not match IPv4-mapped IPv6 addresses (e.g. ::ffff:127.0.0.1), allowing SSRF protection to be bypassed on dual-stack systems. Version 2.3.0 fixes the issue.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2026-47684?

2 open source packages ship an affected version, including @sync-in/server.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@sync-in/server` | npm | All versions | 2.3.0 |
| `@sync-in/server` | npm | All versions | 2.3.0 |

## How do I fix CVE-2026-47684?

Upgrade @sync-in/server to 2.3.0 or later.

## Is CVE-2026-47684 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-47684 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-47684 and fix it if it is affected.

What it is: CVE-2026-47684 is a high-severity server-side request forgery vulnerability in Sync-in server, published on 16 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-47684 exists.

Affected packages and fixed versions:
- @sync-in/server (npm): affected all versions; fixed in 2.3.0
- @sync-in/server (npm): affected all versions; fixed in 2.3.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-47684/ (Markdown: https://insights.sbomify.com/CVE-2026-47684/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-47684
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-47684
- OSV: https://osv.dev/vulnerability/CVE-2026-47684

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-47684/
Summaries are generated and may contain mistakes; the official description above is the record.
