# CVE-2026-47686: vm2: Missing Error.cause Sanitization Enables VM2 Sandbox Escape to RCE

> Attackers can escape the vm2 sandbox and execute arbitrary host commands by exploiting unsanitized Error.cause properties in exception handling.

- **Severity:** Critical 9.9 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Aug 2026
- **Updated:** 19 Aug 2026
- **Also known as:** CLEANSTART-2026-PD83197, ECHO-728a-4ca3-07f3, GHSA-m283-3h24-438v, MINI-qhpq-vwxw-56cv, ROOT-APP-NPM-CVE-2026-47686

## What is CVE-2026-47686?

CVE-2026-47686 is a critical code injection vulnerability in patriksimek vm2, published on 17 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

vm2 is an open source vm/sandbox for Node.js. Prior to 3.11.6, handleException() in lib/setup-sandbox.js sanitizes SuppressedError.error, SuppressedError.suppressed, and AggregateError.errors but does not sanitize Error.cause, allowing sandbox code to obtain a powerful host object such as process from an embedder-exposed host function that throws an error with that object as its cause and then execute arbitrary host commands. This issue is fixed in version 3.11.6.

Weakness: CWE-693 (Protection Mechanism Failure)

## Which versions are affected by CVE-2026-47686?

2 open source packages ship an affected version, including vm2.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `vm2` | npm | All versions | 3.11.6 |
| `vm2` | npm | All versions | 3.11.6 |

## How do I fix CVE-2026-47686?

Upgrade vm2 to 3.11.6 or later.

## Is CVE-2026-47686 being exploited?

There is no known exploitation of CVE-2026-47686 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-47686 and fix it if it is affected.

What it is: CVE-2026-47686 is a critical code injection vulnerability in patriksimek vm2, published on 17 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-47686 in the wild and no public exploit code.

Affected packages and fixed versions:
- vm2 (npm): affected all versions; fixed in 3.11.6
- vm2 (npm): affected all versions; fixed in 3.11.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-47686/ (Markdown: https://insights.sbomify.com/CVE-2026-47686/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-47686
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-47686
- OSV: https://osv.dev/vulnerability/CVE-2026-47686

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-47686/
Summaries are generated and may contain mistakes; the official description above is the record.
