# CVE-2026-47698: vm2: Sandbox Breakout Using Dangerous Host Proto Mutators

> Attackers can escape the vm2 sandbox to execute arbitrary host commands via prototype chain manipulation. Developers using vm2 for isolation must upgrade.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Aug 2026
- **Updated:** 19 Aug 2026
- **Also known as:** CLEANSTART-2026-SV74760, ECHO-9f22-2489-f01b, GHSA-cfcw-xp6x-25gj, MINI-fvvm-j7cx-w636, ROOT-APP-NPM-CVE-2026-47698

## What is CVE-2026-47698?

CVE-2026-47698 is a critical code injection vulnerability in patriksimek vm2, published on 17 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

vm2 is an open source vm/sandbox for Node.js. Prior to 3.11.6, lib/bridge.js and lib/setup-sandbox.js fail to block stacked indirection through Function.prototype.call around dangerous host prototype getter and setter mutators, allowing sandbox code to sever a host intrinsic's prototype chain and reach e.constructor.constructor for arbitrary host command execution. This issue is fixed in version 3.11.6.

Weakness: CWE-913 (Improper Control of Dynamically-Managed Code Resources)

## Which versions are affected by CVE-2026-47698?

2 open source packages ship an affected version, including vm2.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `vm2` | npm | All versions | 3.11.6 |
| `vm2` | npm | All versions | 3.11.6 |

## How do I fix CVE-2026-47698?

Upgrade vm2 to 3.11.6 or later.

## Is CVE-2026-47698 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-47698 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-47698 and fix it if it is affected.

What it is: CVE-2026-47698 is a critical code injection vulnerability in patriksimek vm2, published on 17 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-47698 exists.

Affected packages and fixed versions:
- vm2 (npm): affected all versions; fixed in 3.11.6
- vm2 (npm): affected all versions; fixed in 3.11.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-47698/ (Markdown: https://insights.sbomify.com/CVE-2026-47698/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-47698
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-47698
- OSV: https://osv.dev/vulnerability/CVE-2026-47698

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-47698/
Summaries are generated and may contain mistakes; the official description above is the record.
