# CVE-2026-47707: Strawberry GraphQL's Bypass of MaxAliasesLimiter via Fragment Spreads leading to GraphQL Alias Amplification

> Attackers can bypass alias limits in Strawberry GraphQL via fragment spreads, causing resource exhaustion and denial of service.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 4 Jun 2026
- **Updated:** 4 Jun 2026
- **Also known as:** GHSA-fr49-mhgj-crfc, PYSEC-2026-2284, ROOT-APP-PYPI-CVE-2026-47707

## What is CVE-2026-47707?

CVE-2026-47707 is a medium-severity denial of service vulnerability in strawberry-graphql strawberry, published on 4 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Strawberry GraphQL is a library for creating GraphQL APIs. In versions 0.172.0 through0.315.6, the MaxAliasesLimiter extension in Strawberry fails to account for the multiplicative/amplification effect of FragmentSpreadNode. While it correctly counts static aliases within the AST it does not consider how many times a fragments internal aliases are expanded during execution. this allows an attacker to bypass alias limits and force the server to resolve and render a significantly higher number of aliases than allowed, potentially leading to a  dos via resource exhaustion. Version 0.315.7 contains a fix for the issue.

Weakness: CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2026-47707?

3 open source packages ship an affected version, including strawberry-graphql. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `strawberry-graphql` | PyPI | From 0.172.0 | 0.315.7 |
| `strawberry-graphql` | PyPI | From 0.172.0 | 0.315.7 |
| `strawberry-graphql` | PyPI | From 0.172.0 | 0.315.7 |

Products: Strawberry Strawberry Graphql.

## How do I fix CVE-2026-47707?

Upgrade strawberry-graphql to 0.315.7 or later.

## Is CVE-2026-47707 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-47707 exists.

## Other vulnerabilities in strawberry-graphql strawberry

- [CVE-2026-35523](https://insights.sbomify.com/CVE-2026-35523/): Authentication bypass in strawberry-graphql via legacy graphql-ws WebSocket subprotocol (high 7.5)
- [CVE-2026-35526](https://insights.sbomify.com/CVE-2026-35526/): Strawberry GraphQL affected by a Denial of Service via unbounded WebSocket subscriptions (high 7.5)
- [CVE-2026-47706](https://insights.sbomify.com/CVE-2026-47706/): Strawberry GraphQL has a Circular Fragment Reference DOS (medium 5.3)
- [CVE-2026-45739](https://insights.sbomify.com/CVE-2026-45739/): Strawberry GraphQL: Default GraphiQL may expose HTTP headers in URLs (low 3.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-47707 and fix it if it is affected.

What it is: CVE-2026-47707 is a medium-severity denial of service vulnerability in strawberry-graphql strawberry, published on 4 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-47707 exists.

Affected packages and fixed versions:
- strawberry-graphql (PyPI): affected from 0.172.0; fixed in 0.315.7
- strawberry-graphql (PyPI): affected from 0.172.0; fixed in 0.315.7
- strawberry-graphql (PyPI): affected from 0.172.0; fixed in 0.315.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-47707/ (Markdown: https://insights.sbomify.com/CVE-2026-47707/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-47707
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-47707
- OSV: https://osv.dev/vulnerability/CVE-2026-47707

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-47707/
Summaries are generated and may contain mistakes; the official description above is the record.
