# CVE-2026-47717: FUXA's Unauthenticated Project Data Disclosure Exposes Server-Side Scripts and Device Configurations

> Unauthenticated attackers can access sensitive project configurations and server-side scripts via the API, exposing SCADA device details.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Aug 2026
- **Updated:** 13 Aug 2026
- **Also known as:** GHSA-q3w6-q3hc-c5x6

## What is CVE-2026-47717?

CVE-2026-47717 is a high-severity vulnerability in frangoteam FUXA, published on 12 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

FUXA is a web-based Process Visualization (SCADA/HMI/Dashboard) software. In fuxa-server version 1.3.0, the GET /api/project endpoint exposes sensitive project configuration data to guest-context requests even when secureEnabled is enabled. Version 1.3.1 fixes the issue.

Weakness: CWE-201 (Insertion of Sensitive Information Into Sent Data)

## Which versions are affected by CVE-2026-47717?

2 open source packages ship an affected version, including fuxa-server.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `fuxa-server` | npm | From 1.3.0 | 1.3.1 |
| `fuxa-server` | npm | From 1.3.0 | 1.3.1 |

## How do I fix CVE-2026-47717?

Upgrade fuxa-server to 1.3.1 or later.

## Is CVE-2026-47717 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-47717 exists.

Public exploit code:

- FUXA 1.3.0 - Unauthenticated ICS/SCADA Project Data Disclosure (nuclei): http/cves/2026/CVE-2026-47717.yaml

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-47717 and fix it if it is affected.

What it is: CVE-2026-47717 is a high-severity vulnerability in frangoteam FUXA, published on 12 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-47717 exists.

Affected packages and fixed versions:
- fuxa-server (npm): affected from 1.3.0; fixed in 1.3.1
- fuxa-server (npm): affected from 1.3.0; fixed in 1.3.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-47717/ (Markdown: https://insights.sbomify.com/CVE-2026-47717/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-47717
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-47717
- OSV: https://osv.dev/vulnerability/CVE-2026-47717

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-47717/
Summaries are generated and may contain mistakes; the official description above is the record.
