# CVE-2026-47718: FUXA provides guest and invalid-token access to protected read APIs in secure mode

> Attackers can access protected SCADA data via guest or invalid tokens when secure mode is enabled, exposing sensitive operational information.

- **Severity:** Medium 5.5 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Aug 2026
- **Updated:** 14 Aug 2026
- **Also known as:** GHSA-r9g5-7q8j-958c

## What is CVE-2026-47718?

CVE-2026-47718 is a medium-severity missing authorization vulnerability in frangoteam FUXA, published on 12 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

FUXA is a web-based Process Visualization (SCADA/HMI/Dashboard) software. When `secureEnabled=true`, FUXA `1.3.0-2773` still allows guest and invalid-token requests to read project, alarms, and scheduler APIs. Version 1.3.1 fixes this issue.

Weakness: CWE-862 (Missing Authorization), CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2026-47718?

2 open source packages ship an affected version, including fuxa-server.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `fuxa-server` | npm | From 1.3.0-2773 | 1.3.1 |
| `fuxa-server` | npm | From 1.3.0-2773 | 1.3.1 |

## How do I fix CVE-2026-47718?

Upgrade fuxa-server to 1.3.1 or later.

## Is CVE-2026-47718 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-47718 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-47718 and fix it if it is affected.

What it is: CVE-2026-47718 is a medium-severity missing authorization vulnerability in frangoteam FUXA, published on 12 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-47718 exists.

Affected packages and fixed versions:
- fuxa-server (npm): affected from 1.3.0-2773; fixed in 1.3.1
- fuxa-server (npm): affected from 1.3.0-2773; fixed in 1.3.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-47718/ (Markdown: https://insights.sbomify.com/CVE-2026-47718/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-47718
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-47718
- OSV: https://osv.dev/vulnerability/CVE-2026-47718

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-47718/
Summaries are generated and may contain mistakes; the official description above is the record.
