# CVE-2026-47728: Bugsink: Project scoping missing in sourcemap and debug-file lookup

> Authenticated users can access sourcemap and debug-file metadata from other projects due to missing project scoping in lookup logic.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 26 May 2026
- **Updated:** 26 May 2026
- **Also known as:** GHSA-5389-f7vh-wxj8, PYSEC-2026-2402

## What is CVE-2026-47728?

CVE-2026-47728 is a medium-severity missing authorization vulnerability in bugsink, published on 26 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Bugsink is a self-hosted error tracking tool. Prior to 2.2.0, Bugsink resolved sourcemaps and debug files by debug ID without scoping that lookup to the project that owned the uploaded metadata. An authenticated user with access to one project could cause event processing in that project to use sourcemap/debug-file metadata uploaded for another project in the same Bugsink instance, if the same debug ID was referenced. This vulnerability is fixed in 2.2.0.

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2026-47728?

3 open source packages ship an affected version, including bugsink.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `bugsink` | PyPI | All versions | 2.2.0 |
| `bugsink` | PyPI | All versions | 2.2.0 |
| `bugsink` | PyPI | All versions | 2.2.0 |

## How do I fix CVE-2026-47728?

Upgrade bugsink to 2.2.0 or later.

## Is CVE-2026-47728 being exploited?

There is no known exploitation of CVE-2026-47728 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-47728 and fix it if it is affected.

What it is: CVE-2026-47728 is a medium-severity missing authorization vulnerability in bugsink, published on 26 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-47728 in the wild and no public exploit code.

Affected packages and fixed versions:
- bugsink (PyPI): affected all versions; fixed in 2.2.0
- bugsink (PyPI): affected all versions; fixed in 2.2.0
- bugsink (PyPI): affected all versions; fixed in 2.2.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-47728/ (Markdown: https://insights.sbomify.com/CVE-2026-47728/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-47728
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-47728
- OSV: https://osv.dev/vulnerability/CVE-2026-47728

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-47728/
Summaries are generated and may contain mistakes; the official description above is the record.
