# CVE-2026-47731: NASA AMMOS Instrument Toolkit: Path traversal resulting in arbitrary file append (can be triggered over the network by unauthenticated attacker)

> Unauthenticated remote attackers can exploit path traversal in the Binary Stream Capture component to append arbitrary data to files, potentially leading to code execution.

- **Severity:** Critical 9.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 21 Jul 2026
- **Updated:** 22 Jul 2026
- **Also known as:** GHSA-p462-prxw-mjx4, PYSEC-2026-265

## What is CVE-2026-47731?

CVE-2026-47731 is a critical path traversal vulnerability in NASA-AMMOS AIT-Core, published on 21 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The AMMOS Instrument Toolkit (Formerly the Bespoke Links to Instruments for Surface and Space (BLISS)) is a Python-based software suite developed to handle Ground Data System (GDS), Electronic Ground Support Equipment (EGSE), commanding, telemetry uplink/downlink, and sequencing for instrument and CubeSat Missions. In versions prior to 2.6.1 and in version 3.1.0, the Binary Stream Capture (BSC) component exposes an unauthenticated HTTP API for dynamically creating packet capture "handlers." Because the code blindly trusts path‑related form fields, a remote client can bypass the configured log root and direct BSC to log to arbitrary filesystem paths (path traversal / directory escape), and append attacker‑controlled data to those files, using the privileges of the`ait-bsc` process. There are two ways for a remote attacker to trigger this. First, if the attacker has access to the network where `ait-bsc` is deployed (a reason for that could be that the ports are publicly accessible), the payloads can be directly sent to the server to trigger the arbitrary file append. This type of attack is demonstrated in `python_poc.py`. Second, even if the attacker does not have direct access to the network because the software is running in a local network, it is possible to exploit this if a bad actor in that network opens an attacker-controlled website (which might be a website created by an attacker, or a third-party website compromised by the attacker). The browser javascript can automatically send the requests necessary to exploit this into the local network. This is even possible if the server is only accessible on `localhost`. This type of attack is demonstrated by `attacker_tcp.py` and `test1.html` (first launch the attacker TCP server, then start a webserver to host `test1.html`, for example using `python3 -m http.server 7000`, and open `test1.html`).This issue affects BSC (Binary Stream Capture) and usage of the ait-bsc server. This impacts AIT-Core versions before 3.1.1, from 2.x before 2.6.1. Users are recommended to upgrade to version 3.1.1 or 2.6.1.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2026-47731?

5 open source packages ship an affected version, including ait-core.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ait-core` | PyPI | All versions | 2.6.1, 3.1.1 |
| `ait-core` | PyPI | All versions | 2.6.1 |
| `ait-core` | PyPI | All versions | 2.6.1 |
| `ait-core` | PyPI | From 3.1.0 | 3.1.1 |
| `ait-core` | PyPI | From 3.1.0 | 3.1.1 |

## How do I fix CVE-2026-47731?

Upgrade ait-core to a fixed version for your release line: 2.6.1 or 3.1.1.

## Is CVE-2026-47731 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-47731 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-47731 and fix it if it is affected.

What it is: CVE-2026-47731 is a critical path traversal vulnerability in NASA-AMMOS AIT-Core, published on 21 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-47731 exists.

Affected packages and fixed versions:
- ait-core (PyPI): affected all versions; fixed in 2.6.1, 3.1.1
- ait-core (PyPI): affected all versions; fixed in 2.6.1
- ait-core (PyPI): affected all versions; fixed in 2.6.1
- ait-core (PyPI): affected from 3.1.0; fixed in 3.1.1
- ait-core (PyPI): affected from 3.1.0; fixed in 3.1.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-47731/ (Markdown: https://insights.sbomify.com/CVE-2026-47731/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-47731
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-47731
- OSV: https://osv.dev/vulnerability/CVE-2026-47731

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-47731/
Summaries are generated and may contain mistakes; the official description above is the record.
