CVE-2026-47734 Dulwich has unbounded memory allocation in receive-pack from crafted thin packs
An attacker with push access can cause a denial of service by sending a crafted thin pack that triggers excessive memory allocation in Dulwich Git servers.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2026-47734?
CVE-2026-47734 is a medium-severity denial of service vulnerability in jelmer dulwich, published on 10 Jun 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Official description
Dulwich is a pure-Python implementation of the Git file formats and protocols. Starting in version 0.1.0 and prior to version 1.2.5, a client with push access could push a tiny crafted thin pack (~174 bytes) whose delta header declares a huge dest_size. When dulwich ingested it via add_thin_pack / apply_delta, it would allocate hundreds of MB of memory based on that attacker-controlled size, with no relationship to the actual bytes received. Operators running a Dulwich-based Git server that exposes git-receive-pack (i.e. accepts pushes) - for example via dulwich.server functionality, the HTTP smart server, or anything built on ReceivePackHandler - are impacted. The issue is patched in 1.2.5. add_thin_pack now accepts a max_input_size keyword (bytes; 0/None = unlimited, matching git's semantics), and ReceivePackHandler reads receive.maxInputSize from the repository config and passes it through. Wire reads are counted and a PackInputTooLarge exception is raised once the cap is exceeded - equivalent to git index-pack --max-input-size. Users should upgrade to Dulwich 1.2.5 or later and set receive.maxInputSize in their server's repository config to a sane bound for their environment. On unpatched versions, receive.maxInputSize has no effect, so it cannot be used as a workaround. Until upgrading, operators should restrict dulwich-receive-pack (push) access to trusted, authenticated clients only, or disable it entirely on servers that only need to serve fetches and/or run the server under an OS-level memory limit (e.g. ulimit, cgroups/MemoryMax, or a container memory limit) so a malicious push is killed rather than taking down the host.
Which versions are affected by CVE-2026-47734?
3 open source packages ship an affected version, including dulwich.
| Package | Affected | Fixed in |
|---|---|---|
dulwich PyPI | From 0.1.0 | 1.2.5 |
dulwich PyPI | From 0.1.0 | 1.2.5 |
dulwich PyPI | From 0.1.0 | 1.2.5 |
Linux distribution packages (2)
python3-dulwich SUSE:Linux Enterprise Module for Basesystem 15 SP7 | All versions | 0.20.24-150400.8.1 |
python-dulwich SUSE:Linux Enterprise Module for Public Cloud 12 | All versions | 0.18.5-4.6.1 |
How do I fix CVE-2026-47734?
Upgrade dulwich to 1.2.5 or later.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2026-47734 being exploited?
There is no known exploitation of CVE-2026-47734 in the wild and no public exploit code.
Sources
Also known as AZL-90077, CLEANSTART-2026-BR89758, CLSA-2026-1781484847, DEBIAN-CVE-2026-47734, ECHO-b8a6-4f09-5e73, GHSA-xrvj-v92f-53gj and 6 more.