# CVE-2026-47734: Dulwich has unbounded memory allocation in receive-pack from crafted thin packs

> An attacker with push access can cause a denial of service by sending a crafted thin pack that triggers excessive memory allocation in Dulwich Git servers.

- **Severity:** Medium 5.7 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 10 Jun 2026
- **Updated:** 11 Jun 2026
- **Also known as:** AZL-90077, CLEANSTART-2026-BR89758, CLSA-2026-1781484847, DEBIAN-CVE-2026-47734, ECHO-b8a6-4f09-5e73, GHSA-xrvj-v92f-53gj, MINI-gfq9-rm53-37jm, PYSEC-2026-2466, ROOT-APP-PYPI-CVE-2026-47734, SUSE-SU-2026:2984-1, SUSE-SU-2026:3117-1, UBUNTU-CVE-2026-47734

## What is CVE-2026-47734?

CVE-2026-47734 is a medium-severity denial of service vulnerability in jelmer dulwich, published on 10 Jun 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Dulwich is a pure-Python implementation of the Git file formats and protocols. Starting in version 0.1.0 and prior to version 1.2.5, a client with push access could push a tiny crafted thin pack (~174 bytes)  whose delta header declares a huge   dest_size. When dulwich ingested it via  add_thin_pack / apply_delta, it would  allocate hundreds of MB of memory based on that attacker-controlled size, with no relationship to the actual bytes received. Operators running a Dulwich-based Git server that exposes git-receive-pack (i.e. accepts pushes) - for example via dulwich.server functionality, the HTTP  smart server, or anything built on ReceivePackHandler - are impacted. The issue is patched in 1.2.5. add_thin_pack now accepts a max_input_size keyword (bytes; 0/None = unlimited, matching git's semantics), and ReceivePackHandler reads receive.maxInputSize from the repository config and passes it through. Wire reads are counted and a PackInputTooLarge exception is raised once the cap is exceeded - equivalent to git index-pack --max-input-size. Users should upgrade to Dulwich 1.2.5 or later and set receive.maxInputSize in their server's repository config to a sane bound for their environment. On unpatched versions, receive.maxInputSize has no effect, so it cannot be used as a workaround. Until upgrading, operators should restrict dulwich-receive-pack (push) access to trusted, authenticated clients only, or disable it entirely on servers that only need to serve fetches and/or run the server under an OS-level memory limit (e.g. ulimit, cgroups/MemoryMax, or a container memory limit) so a malicious push is killed rather than taking down the host.

Weakness: CWE-789 (Memory Allocation with Excessive Size Value), CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2026-47734?

3 open source packages ship an affected version, including dulwich.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `dulwich` | PyPI | From 0.1.0 | 1.2.5 |
| `dulwich` | PyPI | From 0.1.0 | 1.2.5 |
| `dulwich` | PyPI | From 0.1.0 | 1.2.5 |
| `python3-dulwich` | SUSE:Linux Enterprise Module for Basesystem 15 SP7 | All versions | 0.20.24-150400.8.1 |
| `python-dulwich` | SUSE:Linux Enterprise Module for Public Cloud 12 | All versions | 0.18.5-4.6.1 |

## How do I fix CVE-2026-47734?

Upgrade dulwich to 1.2.5 or later.

## Is CVE-2026-47734 being exploited?

There is no known exploitation of CVE-2026-47734 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-47734 and fix it if it is affected.

What it is: CVE-2026-47734 is a medium-severity denial of service vulnerability in jelmer dulwich, published on 10 Jun 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-47734 in the wild and no public exploit code.

Affected packages and fixed versions:
- dulwich (PyPI): affected from 0.1.0; fixed in 1.2.5
- dulwich (PyPI): affected from 0.1.0; fixed in 1.2.5
- dulwich (PyPI): affected from 0.1.0; fixed in 1.2.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-47734/ (Markdown: https://insights.sbomify.com/CVE-2026-47734/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-47734
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-47734
- OSV: https://osv.dev/vulnerability/CVE-2026-47734

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-47734/
Summaries are generated and may contain mistakes; the official description above is the record.
