# CVE-2026-47739: Frappe: Stored XSS in Note

> Attackers can inject malicious scripts into Frappe Notes due to missing sanitization, potentially leading to session hijacking or code execution.

- **Severity:** Medium 6.9 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 12 Jun 2026
- **Updated:** 12 Jun 2026
- **Also known as:** GHSA-vxmp-h244-wv3r

## What is CVE-2026-47739?

CVE-2026-47739 is a medium-severity cross-site scripting vulnerability in frappe, published on 12 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Frappe is a full-stack web application framework. Prior to versions 15.106.0 and 16.16.0, stored XSS in Note was possible due to lack of sanitization. This issue has been patched in versions 15.106.0 and 16.16.0.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-47739?


## How do I fix CVE-2026-47739?

No fix has been published for CVE-2026-47739 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-47739 being exploited?

There is no known exploitation of CVE-2026-47739 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-47739 and fix it if it is affected.

What it is: CVE-2026-47739 is a medium-severity cross-site scripting vulnerability in frappe, published on 12 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-47739 in the wild and no public exploit code.

Affected product: frappe. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-47739/ (Markdown: https://insights.sbomify.com/CVE-2026-47739/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-47739
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-47739
- OSV: https://osv.dev/vulnerability/CVE-2026-47739

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-47739/
Summaries are generated and may contain mistakes; the official description above is the record.
