# CVE-2026-47740: Shopper: Authorization bypass in multiple Livewire admin components

> Low-privilege users can modify order states and trigger real payment captures in the Shopper admin panel due to missing authorization checks.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 29 May 2026
- **Updated:** 2 Jun 2026
- **Also known as:** GHSA-f946-9qp6-vgch

## What is CVE-2026-47740?

CVE-2026-47740 is a high-severity missing authorization vulnerability in shopperlabs shopper, published on 29 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Shopper is a Headless e-commerce Admin Panel. Prior to 2.8.0, Multiple Filament actions on the admin Order detail and Order shipments table were callable by an authenticated low-privilege user without the permission required to mutate orders. The order detail actions cancel, mark paid, mark complete, capture payment, archive, and start processing were callable with the read-only read_orders permission and did not require edit_orders. capturePayment could trigger an actual PSP capture (real funds movement). The order shipments table actions mark delivered and edit tracking were callable with the read-only browse_orders permission. A user with read access to orders could therefore alter the lifecycle of every order in the panel and trigger real-world payment captures. This vulnerability is fixed in 2.8.0.

Weakness: CWE-862 (Missing Authorization), CWE-285 (Improper Authorization)

## Which versions are affected by CVE-2026-47740?

2 open source packages ship an affected version, including shopper/framework.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `shopper/framework` | Packagist | All versions | 2.8.0 |
| `shopper/framework` | Packagist | All versions | 2.8.0 |

## How do I fix CVE-2026-47740?

Upgrade shopper/framework to 2.8.0 or later.

## Is CVE-2026-47740 being exploited?

There is no known exploitation of CVE-2026-47740 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-47740 and fix it if it is affected.

What it is: CVE-2026-47740 is a high-severity missing authorization vulnerability in shopperlabs shopper, published on 29 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-47740 in the wild and no public exploit code.

Affected packages and fixed versions:
- shopper/framework (Packagist): affected all versions; fixed in 2.8.0
- shopper/framework (Packagist): affected all versions; fixed in 2.8.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-47740/ (Markdown: https://insights.sbomify.com/CVE-2026-47740/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-47740
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-47740
- OSV: https://osv.dev/vulnerability/CVE-2026-47740

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-47740/
Summaries are generated and may contain mistakes; the official description above is the record.
