# CVE-2026-47741: Shopper: Race condition on Discount.usage_limit allows silent over-redemption

> Attackers can exploit a race condition to exceed discount usage limits, causing financial loss for merchants via over-redemption of coupons.

- **Severity:** Medium 5.9 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 29 May 2026
- **Updated:** 29 May 2026
- **Also known as:** GHSA-9rh9-hf3w-9fgg

## What is CVE-2026-47741?

CVE-2026-47741 is a medium-severity vulnerability in shopperlabs shopper, published on 29 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Shopper is a Headless e-commerce Admin Panel. Prior to 2.8.0, CreateOrderFromCartAction::execute previously created the Order row before checking and incrementing the discount's total_use counter. Under concurrent checkout pressure (Black Friday, flash sale, viral coupon), the global usage_limit was silently exceeded: orders were committed with the discount fully applied to price_amount while the counter blocked at usage_limit. The merchant had no signal that an over-redemption had occurred. This vulnerability is fixed in 2.8.0.

Weakness: CWE-362 (Concurrent Execution using Shared Resource with Improper Synchronization)

## Which versions are affected by CVE-2026-47741?

2 open source packages ship an affected version, including shopper/cart.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `shopper/cart` | Packagist | All versions | 2.8.0 |
| `shopper/cart` | Packagist | All versions | 2.8.0 |

## How do I fix CVE-2026-47741?

Upgrade shopper/cart to 2.8.0 or later.

## Is CVE-2026-47741 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-47741 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-47741 and fix it if it is affected.

What it is: CVE-2026-47741 is a medium-severity vulnerability in shopperlabs shopper, published on 29 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-47741 exists.

Affected packages and fixed versions:
- shopper/cart (Packagist): affected all versions; fixed in 2.8.0
- shopper/cart (Packagist): affected all versions; fixed in 2.8.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-47741/ (Markdown: https://insights.sbomify.com/CVE-2026-47741/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-47741
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-47741
- OSV: https://osv.dev/vulnerability/CVE-2026-47741

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-47741/
Summaries are generated and may contain mistakes; the official description above is the record.
