# CVE-2026-47742: Shopper: Missing authorization on Product admin Livewire sub-form components

> Authenticated users can modify any product's data without proper authorization due to missing checks in Livewire components.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 29 May 2026
- **Updated:** 1 Jun 2026
- **Also known as:** GHSA-h4mp-g9c6-xwph

## What is CVE-2026-47742?

CVE-2026-47742 is a medium-severity missing authorization vulnerability in shopperlabs shopper, published on 29 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Shopper is a Headless e-commerce Admin Panel. Prior to 2.8.0, Sub-form Livewire components used in the product editor (Edit, Inventory, Seo, Shipping, Files) had no authorization on their store() method. Any authenticated panel user, regardless of role, could mutate any product's pricing, stock, SEO metadata, shipping dimensions, and attached media without holding edit_products. The affected components accepted the product ID as a public Livewire property without #[Locked], so an attacker could also target an arbitrary product by tampering with the wire payload from the client. This vulnerability is fixed in 2.8.0.

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2026-47742?

2 open source packages ship an affected version, including shopper/framework.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `shopper/framework` | Packagist | All versions | 2.8.0 |
| `shopper/framework` | Packagist | All versions | 2.8.0 |

## How do I fix CVE-2026-47742?

Upgrade shopper/framework to 2.8.0 or later.

## Is CVE-2026-47742 being exploited?

There is no known exploitation of CVE-2026-47742 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-47742 and fix it if it is affected.

What it is: CVE-2026-47742 is a medium-severity missing authorization vulnerability in shopperlabs shopper, published on 29 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-47742 in the wild and no public exploit code.

Affected packages and fixed versions:
- shopper/framework (Packagist): affected all versions; fixed in 2.8.0
- shopper/framework (Packagist): affected all versions; fixed in 2.8.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-47742/ (Markdown: https://insights.sbomify.com/CVE-2026-47742/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-47742
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-47742
- OSV: https://osv.dev/vulnerability/CVE-2026-47742

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-47742/
Summaries are generated and may contain mistakes; the official description above is the record.
