# CVE-2026-47745: Shopper: Missing per-action authorization on PaymentMethods, Currencies and Carriers admin tables

> Low-privilege users can disable payment methods, currencies, and carriers due to missing per-action authorization checks in the admin panel.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 29 May 2026
- **Updated:** 29 May 2026
- **Also known as:** GHSA-fxqw-97cc-7g5c

## What is CVE-2026-47745?

CVE-2026-47745 is a medium-severity missing authorization vulnerability in shopperlabs shopper, published on 29 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Shopper is a Headless e-commerce Admin Panel. Prior to 2.8.0, the admin tables for PaymentMethods, Currencies and Carriers exposed inline toggles and per-record actions (enable, disable, edit, delete) that were rendered for any authenticated panel user without checking the corresponding per-action permission. A low-privilege user could disable every payment method on the store, disable or alter the default currency, or disable carriers. The impact is a full denial of checkout and pricing integrity loss, reachable by any authenticated user. This vulnerability is fixed in 2.8.0.

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2026-47745?

2 open source packages ship an affected version, including shopper/framework.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `shopper/framework` | Packagist | All versions | 2.8.0 |
| `shopper/framework` | Packagist | All versions | 2.8.0 |

## How do I fix CVE-2026-47745?

Upgrade shopper/framework to 2.8.0 or later.

## Is CVE-2026-47745 being exploited?

There is no known exploitation of CVE-2026-47745 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-47745 and fix it if it is affected.

What it is: CVE-2026-47745 is a medium-severity missing authorization vulnerability in shopperlabs shopper, published on 29 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-47745 in the wild and no public exploit code.

Affected packages and fixed versions:
- shopper/framework (Packagist): affected all versions; fixed in 2.8.0
- shopper/framework (Packagist): affected all versions; fixed in 2.8.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-47745/ (Markdown: https://insights.sbomify.com/CVE-2026-47745/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-47745
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-47745
- OSV: https://osv.dev/vulnerability/CVE-2026-47745

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-47745/
Summaries are generated and may contain mistakes; the official description above is the record.
