# CVE-2026-47759: TinyMCE Cross-Site Scripting (XSS) vulnerability using through data-mce- prefixed src, href, style attributes

> Attackers can inject malicious scripts via unsanitized data-mce attributes in TinyMCE, leading to stored XSS and potential code execution.

- **Severity:** High 8.7 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 28 May 2026
- **Updated:** 30 May 2026
- **Also known as:** CLEANSTART-2026-KI92427, CLEANSTART-2026-UG66310, GHSA-q742-qvgc-gc2f, UBUNTU-CVE-2026-47759

## What is CVE-2026-47759?

CVE-2026-47759 is a high-severity cross-site scripting vulnerability in tinymce, published on 28 May 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

TinyMCE is an open source rich text editor. Prior to 5.11.1, 7.9.3, and 8.5.1, there is a stored XSS vulnerability via unsanitized data-mce-* attributes (data-mce-href, data-mce-src, data-mce-style). Allows attackers to inject malicious values that override safe attributes during serialization, bypassing validation. This vulnerability is fixed in 5.11.1, 7.9.3, and 8.5.1.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-47759?

18 open source packages ship an affected version, including TinyMCE, tinymce/tinymce and tinymce. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `TinyMCE` | NuGet | All versions to 5.10.9 | None |
| `TinyMCE` | NuGet | All versions to 5.10.9 | None |
| `TinyMCE` | NuGet | From 6.0.0 | 7.9.3 |
| `TinyMCE` | NuGet | From 6.0.0 | 7.9.3 |
| `TinyMCE` | NuGet | From 8.0.0 | 8.5.1 |
| `TinyMCE` | NuGet | From 8.0.0 | 8.5.1 |
| `tinymce/tinymce` | Packagist | All versions to 5.10.9 | None |
| `tinymce/tinymce` | Packagist | All versions to 5.10.9 | None |
| `tinymce/tinymce` | Packagist | From 6.0.0 | 7.9.3 |
| `tinymce/tinymce` | Packagist | From 6.0.0 | 7.9.3 |
| `tinymce/tinymce` | Packagist | From 8.0.0 | 8.5.1 |
| `tinymce/tinymce` | Packagist | From 8.0.0 | 8.5.1 |
| `tinymce` | npm | All versions to 5.10.9 | None |
| `tinymce` | npm | All versions to 5.10.9 | None |
| `tinymce` | npm | From 6.0.0 | 7.9.3 |
| `tinymce` | npm | From 6.0.0 | 7.9.3 |
| `tinymce` | npm | From 8.0.0 | 8.5.1 |
| `tinymce` | npm | From 8.0.0 | 8.5.1 |

Products: Tiny Tinymce.

## How do I fix CVE-2026-47759?

Upgrade TinyMCE to a fixed version for your release line: 7.9.3 or 8.5.1.

## Is CVE-2026-47759 being exploited?

There is no known exploitation of CVE-2026-47759 in the wild and no public exploit code.

## Other vulnerabilities in tinymce

- [CVE-2026-47760](https://insights.sbomify.com/CVE-2026-47760/): TinyMCE Cross-Site Scripting (XSS) vulnerability using sanitization bypass through nested SVGs (high 8.7)
- [CVE-2026-47761](https://insights.sbomify.com/CVE-2026-47761/): TinyMCE Cross-Site Scripting (XSS) vulnerability using media plugin `data-mce-object` injection (high 8.7)
- [CVE-2026-47762](https://insights.sbomify.com/CVE-2026-47762/): TinyMCE Cross-Site Scripting (XSS) vulnerability through `mce:protected` comments (high 8.7)
- [CVE-2024-21908](https://insights.sbomify.com/CVE-2024-21908/): Cross-site scripting vulnerability in TinyMCE (medium 6.1)
- [CVE-2024-21910](https://insights.sbomify.com/CVE-2024-21910/): Cross-site scripting vulnerability in TinyMCE plugins (medium 6.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-47759 and fix it if it is affected.

What it is: CVE-2026-47759 is a high-severity cross-site scripting vulnerability in tinymce, published on 28 May 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-47759 in the wild and no public exploit code.

Affected packages and fixed versions:
- TinyMCE (NuGet): affected all versions up to 5.10.9; no fix listed
- TinyMCE (NuGet): affected all versions up to 5.10.9; no fix listed
- TinyMCE (NuGet): affected from 6.0.0; fixed in 7.9.3
- TinyMCE (NuGet): affected from 6.0.0; fixed in 7.9.3
- TinyMCE (NuGet): affected from 8.0.0; fixed in 8.5.1
- TinyMCE (NuGet): affected from 8.0.0; fixed in 8.5.1
- tinymce/tinymce (Packagist): affected all versions up to 5.10.9; no fix listed
- tinymce/tinymce (Packagist): affected all versions up to 5.10.9; no fix listed
- tinymce/tinymce (Packagist): affected from 6.0.0; fixed in 7.9.3
- tinymce/tinymce (Packagist): affected from 6.0.0; fixed in 7.9.3
- tinymce/tinymce (Packagist): affected from 8.0.0; fixed in 8.5.1
- tinymce/tinymce (Packagist): affected from 8.0.0; fixed in 8.5.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-47759/ (Markdown: https://insights.sbomify.com/CVE-2026-47759/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-47759
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-47759
- OSV: https://osv.dev/vulnerability/CVE-2026-47759

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-47759/
Summaries are generated and may contain mistakes; the official description above is the record.
