CVE-2026-47760 TinyMCE Cross-Site Scripting (XSS) vulnerability using sanitization bypass through nested SVGs

High 8.7 Published Updated

Attackers can execute arbitrary JavaScript via crafted nested SVG payloads due to sanitizer bypass in TinyMCE rich text editor.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2026-47760?

CVE-2026-47760 is a high-severity cross-site scripting vulnerability in tinymce, published on 28 May 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

TinyMCE is an open source rich text editor. From 6.8.0 to before 7.1.0, TinyMCE contains an XSS vulnerability caused by improper SVG namespace scope handling in the sanitizer. A crafted payload using nested elements can bypass attribute sanitization and execute arbitrary JavaScript. This vulnerability is fixed in 7.1.0.

Weakness: CWE-79

Which versions are affected by CVE-2026-47760?

6 open source packages ship an affected version, including TinyMCE, tinymce/tinymce and tinymce. It affects 1 product.

PackageAffectedFixed in
TinyMCE NuGetFrom 6.8.07.1.0
TinyMCE NuGetFrom 6.8.07.1.0
tinymce/tinymce PackagistFrom 6.8.07.1.0
tinymce/tinymce PackagistFrom 6.8.07.1.0
tinymce npmFrom 6.8.07.1.0
tinymce npmFrom 6.8.07.1.0

Products include Tiny Tinymce.

How do I fix CVE-2026-47760?

Upgrade TinyMCE to 7.1.0 or later.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2026-47760 being exploited?

There is no known exploitation of CVE-2026-47760 in the wild and no public exploit code.

Sources

Also known as GHSA-mh5m-5hw4-5c69, UBUNTU-CVE-2026-47760.

Is CVE-2026-47760 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free