# CVE-2026-47760: TinyMCE Cross-Site Scripting (XSS) vulnerability using sanitization bypass through nested SVGs

> Attackers can execute arbitrary JavaScript via crafted nested SVG payloads due to sanitizer bypass in TinyMCE rich text editor.

- **Severity:** High 8.7 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 28 May 2026
- **Updated:** 2 Jun 2026
- **Also known as:** GHSA-mh5m-5hw4-5c69, UBUNTU-CVE-2026-47760

## What is CVE-2026-47760?

CVE-2026-47760 is a high-severity cross-site scripting vulnerability in tinymce, published on 28 May 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

TinyMCE is an open source rich text editor. From 6.8.0 to before 7.1.0, TinyMCE contains an XSS vulnerability caused by improper SVG namespace scope handling in the sanitizer. A crafted payload using nested elements can bypass attribute sanitization and execute arbitrary JavaScript. This vulnerability is fixed in 7.1.0.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-47760?

6 open source packages ship an affected version, including TinyMCE, tinymce/tinymce and tinymce. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `TinyMCE` | NuGet | From 6.8.0 | 7.1.0 |
| `TinyMCE` | NuGet | From 6.8.0 | 7.1.0 |
| `tinymce/tinymce` | Packagist | From 6.8.0 | 7.1.0 |
| `tinymce/tinymce` | Packagist | From 6.8.0 | 7.1.0 |
| `tinymce` | npm | From 6.8.0 | 7.1.0 |
| `tinymce` | npm | From 6.8.0 | 7.1.0 |

Products: Tiny Tinymce.

## How do I fix CVE-2026-47760?

Upgrade TinyMCE to 7.1.0 or later.

## Is CVE-2026-47760 being exploited?

There is no known exploitation of CVE-2026-47760 in the wild and no public exploit code.

## Other vulnerabilities in tinymce

- [CVE-2026-47759](https://insights.sbomify.com/CVE-2026-47759/): TinyMCE Cross-Site Scripting (XSS) vulnerability using through data-mce- prefixed src, href, style attributes (high 8.7)
- [CVE-2026-47761](https://insights.sbomify.com/CVE-2026-47761/): TinyMCE Cross-Site Scripting (XSS) vulnerability using media plugin `data-mce-object` injection (high 8.7)
- [CVE-2026-47762](https://insights.sbomify.com/CVE-2026-47762/): TinyMCE Cross-Site Scripting (XSS) vulnerability through `mce:protected` comments (high 8.7)
- [CVE-2024-21908](https://insights.sbomify.com/CVE-2024-21908/): Cross-site scripting vulnerability in TinyMCE (medium 6.1)
- [CVE-2024-21910](https://insights.sbomify.com/CVE-2024-21910/): Cross-site scripting vulnerability in TinyMCE plugins (medium 6.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-47760 and fix it if it is affected.

What it is: CVE-2026-47760 is a high-severity cross-site scripting vulnerability in tinymce, published on 28 May 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-47760 in the wild and no public exploit code.

Affected packages and fixed versions:
- TinyMCE (NuGet): affected from 6.8.0; fixed in 7.1.0
- TinyMCE (NuGet): affected from 6.8.0; fixed in 7.1.0
- tinymce/tinymce (Packagist): affected from 6.8.0; fixed in 7.1.0
- tinymce/tinymce (Packagist): affected from 6.8.0; fixed in 7.1.0
- tinymce (npm): affected from 6.8.0; fixed in 7.1.0
- tinymce (npm): affected from 6.8.0; fixed in 7.1.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-47760/ (Markdown: https://insights.sbomify.com/CVE-2026-47760/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-47760
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-47760
- OSV: https://osv.dev/vulnerability/CVE-2026-47760

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-47760/
Summaries are generated and may contain mistakes; the official description above is the record.
