CVE-2026-47761 TinyMCE Cross-Site Scripting (XSS) vulnerability using media plugin `data-mce-object` injection

High 8.7 Published Updated

Attackers can inject malicious scripts via crafted attributes in the media plugin, leading to stored XSS when content is rendered.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2026-47761?

CVE-2026-47761 is a high-severity cross-site scripting vulnerability in tinymce, published on 28 May 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

TinyMCE is an open source rich text editor. Prior to 5.11.1, 7.9.3, and 8.5.1, there is a stored XSS vulnerability in the media plugin. Attackers can inject malicious scripts via crafted data-mce-* attributes, which are executed when content is rendered. Impacts users of TinyMCE with the media plugin enabled. This vulnerability is fixed in 5.11.1, 7.9.3, and 8.5.1.

Weakness: CWE-79

Which versions are affected by CVE-2026-47761?

18 open source packages ship an affected version, including TinyMCE, tinymce/tinymce and tinymce. It affects 1 product.

PackageAffectedFixed in
TinyMCE NuGetAll versions to 5.10.9None
TinyMCE NuGetAll versions to 5.10.9None
TinyMCE NuGetFrom 6.0.07.9.3
TinyMCE NuGetFrom 6.0.07.9.3
TinyMCE NuGetFrom 8.0.08.5.1
TinyMCE NuGetFrom 8.0.08.5.1
12 more packages
tinymce/tinymce PackagistAll versions to 5.10.9None
tinymce/tinymce PackagistAll versions to 5.10.9None
tinymce/tinymce PackagistFrom 6.0.07.9.3
tinymce/tinymce PackagistFrom 6.0.07.9.3
tinymce/tinymce PackagistFrom 8.0.08.5.1
tinymce/tinymce PackagistFrom 8.0.08.5.1
tinymce npmAll versions to 5.10.9None
tinymce npmAll versions to 5.10.9None
tinymce npmFrom 6.0.07.9.3
tinymce npmFrom 6.0.07.9.3
tinymce npmFrom 8.0.08.5.1
tinymce npmFrom 8.0.08.5.1

Products include Tiny Tinymce.

How do I fix CVE-2026-47761?

Upgrade TinyMCE to a fixed version for your release line: 7.9.3 or 8.5.1.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2026-47761 being exploited?

There is no known exploitation of CVE-2026-47761 in the wild and no public exploit code.

Public exploit code: 1 proofs of concept on GitHub.

Sources

Also known as CLEANSTART-2026-LJ04584, CLEANSTART-2026-RN17986, GHSA-vg35-5wq7-3x7w, UBUNTU-CVE-2026-47761.

Is CVE-2026-47761 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free