CVE-2026-47762 TinyMCE Cross-Site Scripting (XSS) vulnerability through `mce:protected` comments
Attackers can inject malicious scripts via forged protected comments in TinyMCE, executing code when content is restored if the protect option is enabled.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2026-47762?
CVE-2026-47762 is a high-severity cross-site scripting vulnerability in tinymce, published on 28 May 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Official description
TinyMCE is an open source rich text editor. Prior to 5.11.1, 7.9.3, and 8.5.1, there is a stored XSS vulnerability via forged mce:protected comments. Allows attackers to bypass sanitization and inject scripts that execute when content is restored. Impacts users who utilize the protect option. This vulnerability is fixed in 5.11.1, 7.9.3, and 8.5.1.
Weakness: CWE-79
Which versions are affected by CVE-2026-47762?
18 open source packages ship an affected version, including TinyMCE, tinymce/tinymce and tinymce. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
TinyMCE NuGet | All versions to 5.10.9 | None |
TinyMCE NuGet | All versions to 5.10.9 | None |
TinyMCE NuGet | From 6.0.0 | 7.9.3 |
TinyMCE NuGet | From 6.0.0 | 7.9.3 |
TinyMCE NuGet | From 8.0.0 | 8.5.1 |
TinyMCE NuGet | From 8.0.0 | 8.5.1 |
12 more packages
tinymce/tinymce Packagist | All versions to 5.10.9 | None |
tinymce/tinymce Packagist | All versions to 5.10.9 | None |
tinymce/tinymce Packagist | From 6.0.0 | 7.9.3 |
tinymce/tinymce Packagist | From 6.0.0 | 7.9.3 |
tinymce/tinymce Packagist | From 8.0.0 | 8.5.1 |
tinymce/tinymce Packagist | From 8.0.0 | 8.5.1 |
tinymce npm | All versions to 5.10.9 | None |
tinymce npm | All versions to 5.10.9 | None |
tinymce npm | From 6.0.0 | 7.9.3 |
tinymce npm | From 6.0.0 | 7.9.3 |
tinymce npm | From 8.0.0 | 8.5.1 |
tinymce npm | From 8.0.0 | 8.5.1 |
Products include Tiny Tinymce.
How do I fix CVE-2026-47762?
Upgrade TinyMCE to a fixed version for your release line: 7.9.3 or 8.5.1.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2026-47762 being exploited?
There is no known exploitation of CVE-2026-47762 in the wild and no public exploit code.
Other vulnerabilities in tinymce
- CVE-2026-47759 TinyMCE Cross-Site Scripting (XSS) vulnerability using through data-mce- prefixed src, href, style attributes
- CVE-2026-47760 TinyMCE Cross-Site Scripting (XSS) vulnerability using sanitization bypass through nested SVGs
- CVE-2026-47761 TinyMCE Cross-Site Scripting (XSS) vulnerability using media plugin `data-mce-object` injection
- CVE-2024-21908 Cross-site scripting vulnerability in TinyMCE
- CVE-2024-21910 Cross-site scripting vulnerability in TinyMCE plugins
Sources
Also known as CLEANSTART-2026-AV82595, CLEANSTART-2026-NJ61543, GHSA-v98h-vmpc-fpqv, UBUNTU-CVE-2026-47762.