{"answers":{"affected":"3 open source packages ship an affected version, including pdm.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-47763 exists.","fix":"Upgrade pdm to 2.27.0 or later.","what":"CVE-2026-47763 is a medium-severity path traversal vulnerability in pdm-project pdm, published on 4 Aug 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-47763 and fix it if it is affected.\n\nWhat it is: CVE-2026-47763 is a medium-severity path traversal vulnerability in pdm-project pdm, published on 4 Aug 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-47763 exists.\n\nAffected packages and fixed versions:\n- pdm (PyPI): affected all versions; fixed in 2.27.0\n- pdm (PyPI): affected all versions; fixed in 2.27.0\n- pdm (PyPI): affected all versions; fixed in 2.27.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-47763/ (Markdown: https://insights.sbomify.com/CVE-2026-47763/index.md)","id":"CVE-2026-47763","markdown":"https://insights.sbomify.com/CVE-2026-47763/index.md","name":"CVE-2026-47763","record":{"aliases":["DEBIAN-CVE-2026-47763","GHSA-ghq2-5c67-fprm","PYSEC-2026-2862","UBUNTU-CVE-2026-47763"],"analysis":{"component_type":"developer_tool","fix_type":"upgrade","impacts":["data_modify"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Python package manager","requires_auth":"none","summary":"Attackers can overwrite arbitrary files via symlinked config files in malicious repositories, leading to data modification.","user_interaction":"required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":6.8,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:A/VC:N/VI:H/VA:L/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-61","name":"UNIX Symbolic Link (Symlink) Following"}],"description":"pdm is a Python package and dependency manager supporting the latest PEP standards. In versions prior to 2.27.0, pdm writes several project-local state or configuration files without symlink protection. If a malicious repository places those files as symlinks, local PDM operations can overwrite the symlink targets. This creates an arbitrary file clobber primitive relative to the privileges of the invoking user. Config.__init__() resolves the project-local pdm.toml path and _save_config() writes to the resolved target. If PROJECT_ROOT/pdm.toml is a symlink to another file, pdm config -l ... updates the target file instead of refusing the write.\nThe same general problem exists for other project-local persistence paths that are written directly with no lstat / O_NOFOLLOW protection. For the pdm.toml PoC specifically, the target file must already contain parseable TOML. Otherwise the load step fails before the write path is reached. That parser constraint does not apply to the .pdm-python or .python-version sinks. This issue has been fixed in version 2.27.0.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"pdm: Project-Local State and Config Writes Follow Symlinks","id":"CVE-2026-47763","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"path_traversal","year":"2026"},"n_packages":3,"n_references":2,"next":{"headline":"pdm: Path traversal in wheel installation via overridden write_to_fs","id":"CVE-2026-47764"},"packages":[{"ecosystem":"PyPI","fixed":["2.27.0"],"introduced":["0"],"last_affected":[],"package":"pdm","purl":null,"source":"GHSA-ghq2-5c67-fprm"},{"ecosystem":"PyPI","fixed":["2.27.0"],"introduced":["0"],"last_affected":[],"package":"pdm","purl":"pkg:pypi/pdm","source":"GHSA-ghq2-5c67-fprm"},{"ecosystem":"PyPI","fixed":["2.27.0"],"introduced":["0"],"last_affected":[],"package":"pdm","purl":"pkg:pypi/pdm","source":"PYSEC-2026-2862"}],"prev":{"headline":"TinyMCE Cross-Site Scripting (XSS) vulnerability through `mce:protected` comments","id":"CVE-2026-47762"},"products":["pdm"],"published":"2026-08-04","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-08-05","vendors":["pdm-project"]},"summary":"Attackers can overwrite arbitrary files via symlinked config files in malicious repositories, leading to data modification.","url":"https://insights.sbomify.com/CVE-2026-47763/"}